summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-27 23:30:32 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-11 18:07:30 +0100
commit4e7fad99144fe4a0b84c803b981b1618d052a794 (patch)
tree65c8eef565bb2dd3b5515f0085ba9b8f263e54bb /gnu/packages/web.scm
parent3d2ea6a50b806ba27db8f1c3c2ad34bb5553b511 (diff)
downloadguix-patches-4e7fad99144fe4a0b84c803b981b1618d052a794.tar
guix-patches-4e7fad99144fe4a0b84c803b981b1618d052a794.tar.gz
gnu: python-feedparser: Enable tests.
* gnu/packages/web.scm (python-feedparser)[source]: Make some cosmetic changes. [arguments]: Remove #:tests?. Override 'check phase. [home-page]: Don't break line. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b2e1e66546..3e6453b874 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2021 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4621,20 +4622,24 @@ their web site.")
(method url-fetch)
(uri (pypi-uri "feedparser" version ".tar.gz"))
(sha256
- (base32
- "0qcnkyjjfj5gg5rhd1j4zzlqx5h34bma18zwgj68q95b0l543q2w"))))
+ (base32 "0qcnkyjjfj5gg5rhd1j4zzlqx5h34bma18zwgj68q95b0l543q2w"))))
(build-system python-build-system)
(propagated-inputs
(list python-sgmllib3k))
(arguments
- '(#:tests? #f))
- (home-page
- "https://github.com/kurtmckee/feedparser")
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "tests/runtests.py")))))))
+ (home-page "https://github.com/kurtmckee/feedparser")
(synopsis "Parse feeds in Python")
(description
"Universal feed parser which handles RSS 0.9x, RSS 1.0, RSS 2.0,
CDF, Atom 0.3, and Atom 1.0 feeds.")
- (license (list license:bsd-2 ; source code
+ (license (list license:bsd-2 ; source code
license:freebsd-doc)))) ; documentation
(define-public python2-feedparser