summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorlsp <lsp@ableton.com>2020-11-17 17:50:06 +0100
committerLudovic Courtès <ludo@gnu.org>2020-12-23 17:30:14 +0100
commit4994e1f2bd9b573d2c13abf2b98ec204f510ad11 (patch)
tree43826b65fc732a7d74ddc2cd2823ac30c8068e73 /gnu/packages/web.scm
parentd6b0d219c6e4e8392fbeb3263c95e9b7d7c75e1c (diff)
downloadguix-patches-4994e1f2bd9b573d2c13abf2b98ec204f510ad11.tar
guix-patches-4994e1f2bd9b573d2c13abf2b98ec204f510ad11.tar.gz
gnu: Add uriparser.
* gnu/packages/web.scm (uriparser): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index cb04d95575..8d7dfe2804 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -118,6 +118,7 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
#:use-module (gnu packages gperf)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
@@ -8002,3 +8003,29 @@ It contains the code shared by all Kiwix ports.")
(description "Kiwix Desktop allows you to enjoy a lot of different content
offline (such as Wikipedia), without any access to Internet.")
(license license:gpl3)))
+
+(define-public uriparser
+ (let ((commit "25dddb16cf044a7df27884e7ad3911baaaca3d7c")
+ (revision "1"))
+ (package
+ (name "uriparser")
+ (version (git-version "0.9.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/uriparser/uriparser")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ffzia679axcsccx2fxjpxhb0i5xc42zxn446x6c1170w6v69qf6"))))
+ (build-system cmake-build-system)
+ (native-inputs `(("gtest" ,googletest)
+ ("doxygen" ,doxygen)
+ ("graphviz" ,graphviz)))
+ (synopsis "Strictly RFC 3986 compliant URI parsing and handling library")
+ (description "uriparser is a strictly RFC 3986 compliant URI parsing and
+handling library written in C89 (\"ANSI C\"). uriparser is fast and supports
+Unicode.")
+ (home-page "https://uriparser.github.io/")
+ (license license:bsd-3))))