summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-12-10 21:49:25 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-12-10 21:49:25 +0100
commit32750e8c3ed38df4cafb39cffa878c6851abc899 (patch)
treedcf40b321c3b492bd1d00244c78f72160e66a554 /gnu/packages/web.scm
parent6104071e483095f9fea9700e0317e84f64102ae2 (diff)
parente1e32303129c5aedc7236d5cc854d6b72ad35daf (diff)
downloadguix-patches-32750e8c3ed38df4cafb39cffa878c6851abc899.tar
guix-patches-32750e8c3ed38df4cafb39cffa878c6851abc899.tar.gz
Merge remote-tracking branch 'signed/master' into core-updates
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm41
1 files changed, 39 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3d4ee58872..d28c60e576 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -53,6 +53,7 @@
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5869,14 +5870,14 @@ on the fly.")
(define-public hitch
(package
(name "hitch")
- (version "1.7.0")
+ (version "1.7.2")
(home-page "https://hitch-tls.org/")
(source (origin
(method url-fetch)
(uri (string-append home-page "source/hitch-" version ".tar.gz"))
(sha256
(base32
- "1i75giwyr66ip8xsvk3gg5xdbxnmcabgxz8dqi06c58mw7qzhzn9"))))
+ "118p3a8wjvr0yhldpd1zm7d2cmgaw4vmyz9ib8m64z18qsz5rmnw"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -8140,6 +8141,42 @@ It contains the code shared by all Kiwix ports.")
offline (such as Wikipedia), without any access to Internet.")
(license license:gpl3)))
+(define-public kiwix-tools
+ (package
+ (name "kiwix-tools")
+ (version "3.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.kiwix.org/release/"
+ "kiwix-tools/kiwix-tools-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1npf9ddhpkmx97gxmvmwmi8a69md8kh2szimd9rpg6ggd4big03a"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("icu4c" ,icu4c)
+ ("kiwix-lib" ,kiwix-lib)
+ ("libmicrohttpd" ,libmicrohttpd)
+ ("libzim" ,libzim)
+ ("pugixml" ,pugixml)
+ ("xapian" ,xapian)
+ ("zlib" ,zlib)
+ ("zstd" ,zstd "lib")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://wiki.kiwix.org/wiki/Software")
+ (synopsis "Kiwix command line tools")
+ (description "The Kiwix tools are a collection of Kiwix-related command line
+tools:
+@itemize
+@item kiwix-manage: Manage XML based library of ZIM files
+@item kiwix-read: Read ZIM file content
+@item kiwix-search: Fulltext search in ZIM files
+@item kiwix-serve: HTTP daemon serving ZIM files
+@end itemize\n")
+ (license license:gpl3+)))
+
(define-public uriparser
(let ((commit "25dddb16cf044a7df27884e7ad3911baaaca3d7c")
(revision "1"))