summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-19 18:12:34 -0400
committerMark H Weaver <mhw@netris.org>2015-07-19 18:12:34 -0400
commit1b4e48d498a96d478baa1aae7d9c7ecdbd817d6f (patch)
tree4b650999e49a6f4d3dd116fab3f9ee8222247e07 /gnu/packages/web.scm
parentaa27987f71cb8afa698ede551e20b1248f160113 (diff)
parent50c7a1e297bff0935674b4f30e854a8889becfdd (diff)
downloadguix-patches-1b4e48d498a96d478baa1aae7d9c7ecdbd817d6f.tar
guix-patches-1b4e48d498a96d478baa1aae7d9c7ecdbd817d6f.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 830d9db7dd..28bd2c7c68 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -365,7 +365,7 @@ files, checks if a given domain is a public suffix, provides immediate cookie
domain verification, finds the longest public part of a given domain, finds
the shortest private part of a given domain, works with international
domains (UTF-8 and IDNA2008 Punycode), is thread-safe, and handles IDNA2008
-UTS#46")
+UTS#46.")
(license l:x11)))
(define-public tidy
@@ -433,7 +433,7 @@ used to validate and fix HTML data.")
;; All of the below are used to generate the documentation
;; (Should they be propagated inputs of asciidoc ??)
(native-inputs `(("asciidoc" ,asciidoc)
- ("libxml2" ,libxml2)
+ ("libxml2" ,libxml2)
("docbook-xml" ,docbook-xml)
("docbook-xsl" ,docbook-xsl)
("libxslt" ,libxslt)))
@@ -979,7 +979,7 @@ for you. It will work even with Catalyst debug logging turned off.")
(home-page "http://search.cpan.org/dist/Catalyst-Plugin-Authentication")
(synopsis "Infrastructure plugin for the Catalyst authentication framework")
(description "The authentication plugin provides generic user support for
-Catalyst apps. It is the basis for both authentication (checking the user is
+Catalyst apps. It is the basis for both authentication (checking the user is
who they claim to be), and authorization (allowing the user to do what the
system authorises them to do).")
(license (package-license perl))))
@@ -1148,7 +1148,7 @@ cookie mechanism.")
("perl-path-class" ,perl-path-class)))
(home-page
"http://search.cpan.org/dist/Catalyst-Plugin-Session-Store-FastMmap")
- (synopsis "FastMmap session storage backend.")
+ (synopsis "FastMmap session storage backend")
(description "Catalyst::Plugin::Session::Store::FastMmap is a fast session
storage plugin for Catalyst that uses an mmap'ed file to act as a shared
memory interprocess cache. It is based on Cache::FastMmap.")
@@ -1327,7 +1327,7 @@ replaced with the contents of the X-Request-Base header.")
(synopsis "Download data in many formats")
(description "The purpose of this module is to provide a method for
downloading data into many supportable formats. For example, downloading a
-table based report in a variety of formats (CSV, HTML, etc.). ")
+table based report in a variety of formats (CSV, HTML, etc.).")
(license (package-license perl))))
(define-public perl-catalyst-view-json
@@ -1567,13 +1567,13 @@ for files and urls.")
(synopsis "Perl locale encoding determination")
(description
"The POSIX locale system is used to specify both the language
-conventions requested by the user and the preferred character set to consume
-and output. The Encode::Locale module looks up the charset and encoding
-(called a CODESET in the locale jargon) and arranges for the Encode module
-to know this encoding under the name \"locale\". It means bytes obtained
-from the environment can be converted to Unicode strings by calling
-Encode::encode(locale => $bytes) and converted back again with
-Encode::decode(locale => $string).")
+conventions requested by the user and the preferred character set to
+consume and output. The Encode::Locale module looks up the charset and
+encoding (called a CODESET in the locale jargon) and arranges for the
+Encode module to know this encoding under the name \"locale\". It means
+bytes obtained from the environment can be converted to Unicode strings
+by calling Encode::encode(locale => $bytes) and converted back again
+with Encode::decode(locale => $string).")
(home-page "http://search.cpan.org/~gaas/Encode-Locale/")))
(define-public perl-file-listing
@@ -2298,7 +2298,7 @@ or to multiple server ports.")
`(("perl-io-socket-ssl" ,perl-io-socket-ssl)))
(home-page "http://search.cpan.org/dist/Net-SMTP-SSL")
(synopsis "SSL support for Net::SMTP")
- (description "SSL support for Net::SMTP")
+ (description "SSL support for Net::SMTP.")
(license (package-license perl))))
(define-public perl-plack