summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-02-09 13:37:01 +0000
committerKei Kebreau <kei@openmailbox.org>2017-02-09 12:15:28 -0500
commit1ad3c7f2e61dc7c284280f3f47e11cb86124ebef (patch)
tree07ffdaf65d2424e686cc00d499824bfce03a447f /gnu/packages/web.scm
parent3a44c7bbdc45616acb4e24d4ddfdc84cdb85d480 (diff)
downloadguix-patches-1ad3c7f2e61dc7c284280f3f47e11cb86124ebef.tar
guix-patches-1ad3c7f2e61dc7c284280f3f47e11cb86124ebef.tar.gz
gnu: Add tidy-html.
* gnu/packages/web.scm (tidy-html): New variable. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm50
1 files changed, 49 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8cc80a2c45..4d138b79fc 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
@@ -4018,3 +4018,51 @@ service for that request. Requests are made using port numbers as identifiers
and xinetd usually launches another daemon to handle the request. It can be
used to start services with both privileged and non-privileged port numbers.")
(license (l:fsf-free "file://COPYRIGHT"))))
+
+(define-public tidy-html
+ (package
+ (name "tidy-html")
+ (version "5.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/htacg/tidy-html5/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0kbwzh15dlapp3s3vff2qgz0yfcf8hwsnx5q4igwa6pimhak8lw0"))))
+ (build-system cmake-build-system)
+ (outputs '("out"
+ "static")) ; 1.0MiB of .a files
+ (arguments
+ `(#:tests? #f ; No tests available
+ #:configure-flags (list "-DCMAKE_BUILD_TYPE=Release")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-static-libraries
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Move static libraries to the "static" output.
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib"))
+ (static (assoc-ref outputs "static"))
+ (slib (string-append static "/lib")))
+ (mkdir-p slib)
+ (for-each (lambda (file)
+ (install-file file slib)
+ (delete-file file))
+ (find-files lib "\\.a$"))
+ #t))))))
+ (native-inputs
+ `(("libxslt" ,libxslt)))
+ (home-page "http://www.html-tidy.org/")
+ (synopsis "HTML Tidy with HTML5 support")
+ (description
+ "Tidy is a console application which corrects and cleans up
+HTML and XML documents by fixing markup errors and upgrading
+legacy code to modern standards.
+
+Tidy also provides @code{libtidy}, a C static and dynamic library that
+developers can integrate into their applications to make use of the
+functions of Tidy.")
+ (license l:bsd-3)))