summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-05-12 15:50:27 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-05-18 11:08:31 +0100
commit006c3f2240d9c4f90205dea12aea5341140087c6 (patch)
tree172bd0023fa2a6f519280995f09b6bd13d24fdf8 /gnu/packages/web.scm
parent5b77e9ca14ff7fc74b849492e96353939f29664b (diff)
downloadguix-patches-006c3f2240d9c4f90205dea12aea5341140087c6.tar
guix-patches-006c3f2240d9c4f90205dea12aea5341140087c6.tar.gz
gnu: Add perl-lwpx-paranoidagent.
* gnu/packages/web.scm (perl-lwpx-paranoidagent): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index eabc3c0197..a3f69e1587 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -126,6 +126,7 @@
#:use-module (gnu packages lua)
#:use-module (gnu packages markup)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages networking)
#:use-module (gnu packages nss)
#:use-module (gnu packages openldap)
#:use-module (gnu packages openstack)
@@ -3718,6 +3719,35 @@ possibly-temporary error (like a DNS lookup timeout), it'll wait a few seconds
and retry a few times.")
(license license:perl-license)))
+(define-public perl-lwpx-paranoidagent
+ (package
+ (name "perl-lwpx-paranoidagent")
+ (version "1.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SA/SAXJAZMAN/lwp/LWPx-ParanoidAgent-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gfhw3jbs25yya2dryv8xvyn9myngcfcmsybj7gkq62fnznil16c"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-libwww" ,perl-libwww)
+ ;; Users should instead make sure SSL_ca_path is set properly.
+ ;; ("perl-mozilla-ca" ,perl-mozilla-ca)
+ ("perl-net-dns" ,perl-net-dns)))
+ (home-page "https://metacpan.org/release/LWPx-ParanoidAgent")
+ (synopsis "Security enhanced subclass of LWP::UserAgent")
+ (description "@code{LWPx::ParanoidAgent} is a class subclassing
+@code{LWP::UserAgent} but paranoid against attackers. Its purpose is
+to vet requests for a remote resource on behalf of a possibly
+malicious user. The class can do the same as @code{LWP::UserAgent},
+except that proxy support has been removed. Support for URI schemes
+is limited to http and https.")
+ (license license:perl-license)))
+
(define-public perl-net-amazon-s3
(package
(name "perl-net-amazon-s3")