summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-19 21:38:20 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-19 21:38:20 +0100
commitfa5a4fb797415a5e209c04dca0f6d21ee1e33e83 (patch)
tree3983690659eaf5232077b1d879cc306fe032d14d /gnu/packages/web-browsers.scm
parentc4da95cad3fd397261e74cfcfffb6f60da1dfecb (diff)
downloadguix-patches-fa5a4fb797415a5e209c04dca0f6d21ee1e33e83.tar
guix-patches-fa5a4fb797415a5e209c04dca0f6d21ee1e33e83.tar.gz
gnu: lagrange: Fix build.
* gnu/packages/web-browsers.scm (lagrange)[argument]<#:phases>: Add phase to fix build. Fixes <https://issues.guix.gnu.org/52664>.
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 8984d6b61b..f8a6a6efed 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -710,7 +710,23 @@ is fully configurable and extensible in Common Lisp.")
(build-system cmake-build-system)
(arguments
`(#:tests? #false ;no tests
- #:configure-flags (list "-DTFDN_ENABLE_SSE41=OFF")))
+ #:configure-flags (list "-DTFDN_ENABLE_SSE41=OFF")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-build-error
+ (lambda _
+ ;; XXX: Remove in next release. Applied upstream. See
+ ;; <https://git.skyjake.fi/gemini/lagrange/commit/b710eee5a92166ceb87932fe53b226be64b4d259>.
+ (substitute* "src/ui/text.c"
+ (("width <= 1") "width && width <= 1")
+ (("colorId") "fgColorId"))
+ (substitute* "src/ui/text_simple.c"
+ (("colorId") "fgColorId")
+ (("const iColor clr =") "iColor clr;")
+ (("ansiForeground_Color\\((.+)\\);" _ params)
+ (string-append "ansiColors_Color("
+ params
+ ", none_ColorId, &clr, NULL);"))))))))
(native-inputs
(list pkg-config zip))
(inputs