summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-04 23:16:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-04 23:16:17 +0100
commitebb7cf9e21060105d9950dd5142c0eb918083666 (patch)
tree36c1607b80d92e27fb9d09029d1d3b57a1fd5065 /gnu/packages/web-browsers.scm
parent0b870f7915f5da43758753fd088a22033936dc50 (diff)
parentc2d7e800e6788277bc56f31d5836f9d507dc1506 (diff)
downloadguix-patches-ebb7cf9e21060105d9950dd5142c0eb918083666.tar
guix-patches-ebb7cf9e21060105d9950dd5142c0eb918083666.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 8778e5e17a..88b74f6cd7 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -392,7 +392,7 @@ driven and does not detract you from your daily work.")
(define next-gtk-webkit
(package
(name "next-gtk-webkit")
- (version "1.4.0")
+ (version "1.5.0")
(source
(origin
(method git-fetch)
@@ -403,7 +403,7 @@ driven and does not detract you from your daily work.")
(commit version)))
(sha256
(base32
- "1gkmr746rqqg94698a051gv79fblc8n9dq0zg04llba44adhpmjl"))
+ "1gqkp185wcwaxr8py90hqk44nqjblrrdwvig19gizrbzr2gx2zhy"))
(file-name (git-file-name "next" version))))
(build-system glib-or-gtk-build-system)
(arguments
@@ -424,11 +424,10 @@ driven and does not detract you from your daily work.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "https://next.atlas.engineer")
- (synopsis "Infinitely extensible web-browser (user interface only)")
+ (synopsis "Extensible web-browser in Common Lisp")
(description "Next is a keyboard-oriented, extensible web-browser
-inspired by Emacs and designed for power users. The application has familiar
-key-bindings, is fully configurable and extensible in Lisp, and has powerful
-features for productive professionals.")
+designed for power users. The application has familiar Emacs and VI
+key-bindings and is fully configurable and extensible in Common Lisp.")
(license license:bsd-3)))
(define sbcl-next-download-manager
@@ -450,7 +449,7 @@ features for productive professionals.")
(native-inputs
`(("trivial-features" ,sbcl-trivial-features)
("prove-asdf" ,sbcl-prove-asdf)))
- (synopsis "Infinitely extensible web-browser (download manager)")))
+ (synopsis "Extensible web-browser in Common Lisp (download manager)")))
(define sbcl-next-ring
(package
@@ -464,7 +463,7 @@ features for productive professionals.")
(native-inputs
`(("trivial-features" ,sbcl-trivial-features)
("prove-asdf" ,sbcl-prove-asdf)))
- (synopsis "Infinitely extensible web-browser (ring)")))
+ (synopsis "Extensible web-browser in Common Lisp (ring)")))
(define sbcl-next-history-tree
(package
@@ -478,7 +477,7 @@ features for productive professionals.")
(native-inputs
`(("trivial-features" ,sbcl-trivial-features)
("prove-asdf" ,sbcl-prove-asdf)))
- (synopsis "Infinitely extensible web-browser (history-tree)")))
+ (synopsis "Extensible web-browser in Common Lisp (history-tree)")))
(define sbcl-next-password-manager
(package
@@ -498,7 +497,7 @@ features for productive professionals.")
(native-inputs
`(("trivial-features" ,sbcl-trivial-features)
("prove-asdf" ,sbcl-prove-asdf)))
- (synopsis "Infinitely extensible web-browser (password manager)")))
+ (synopsis "Extensible web-browser in Common Lisp (password manager)")))
(define sbcl-next-hooks
(package
@@ -617,7 +616,7 @@ features for productive professionals.")
`(("trivial-features" ,sbcl-trivial-features)
("trivial-types" ,sbcl-trivial-types)
("prove-asdf" ,sbcl-prove-asdf)))
- (synopsis "Infinitely extensible web-browser (with Lisp development files)"))))
+ (synopsis "Extensible web-browser in Common Lisp"))))
(define-public sbcl-next
(deprecated-package "sbcl-next" next))