summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-10-06 22:02:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-10-06 22:02:20 +0200
commite08902d3cbb307e1523485becbbdaf9aed56ac4a (patch)
treeca79454c4146f37c0e0f4d354d434816928812ed /gnu/packages/web-browsers.scm
parent1714edc3d4e8d6da1b0cdef300ae882d0885f182 (diff)
parentf58702465d0b2daab1775d29439b73b4486a108a (diff)
downloadguix-patches-e08902d3cbb307e1523485becbbdaf9aed56ac4a.tar
guix-patches-e08902d3cbb307e1523485becbbdaf9aed56ac4a.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm46
1 files changed, 42 insertions, 4 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index f84320f116..6a1eb9324e 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -367,7 +367,7 @@ driven and does not detract you from your daily work.")
(define next-gtk-webkit
(package
(name "next-gtk-webkit")
- (version "1.3.2")
+ (version "1.3.4")
(source
(origin
(method git-fetch)
@@ -378,7 +378,7 @@ driven and does not detract you from your daily work.")
(commit version)))
(sha256
(base32
- "0863p6ch4pdrn6b81cx2abis0ld7r2n6x34v3z0ihj3jlfj21yx4"))
+ "00iqv4xarabl98gdl1rzqkc5v0vfljx1nawsxqsx9x3a9mnxmgxi"))
(file-name (git-file-name "next" version))))
(build-system glib-or-gtk-build-system)
(arguments
@@ -441,6 +441,40 @@ features for productive professionals.")
("prove-asdf" ,sbcl-prove-asdf)))
(synopsis "Infinitely extensible web-browser (ring)")))
+(define sbcl-next-history-tree
+ (package
+ (inherit next-gtk-webkit)
+ (name "sbcl-next-history-tree")
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:tests? #t
+ #:asd-file "next.asd"
+ #:asd-system-name "next/history-tree"))
+ (native-inputs
+ `(("trivial-features" ,sbcl-trivial-features)
+ ("prove-asdf" ,sbcl-prove-asdf)))
+ (synopsis "Infinitely extensible web-browser (history-tree)")))
+
+(define sbcl-next-password-manager
+ (package
+ (inherit next-gtk-webkit)
+ (name "sbcl-next-password-manager")
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:tests? #t
+ #:asd-file "next.asd"
+ #:asd-system-name "next/password-manager"))
+ (inputs
+ `(("bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("cl-annot" ,sbcl-cl-annot)
+ ("cl-ppcre" ,sbcl-cl-ppcre)
+ ("str" ,sbcl-cl-str)
+ ("trivial-clipboard" ,sbcl-trivial-clipboard)))
+ (native-inputs
+ `(("trivial-features" ,sbcl-trivial-features)
+ ("prove-asdf" ,sbcl-prove-asdf)))
+ (synopsis "Infinitely extensible web-browser (password manager)")))
+
(define-public next
(let ((version (package-version next-gtk-webkit)))
(package
@@ -505,12 +539,14 @@ features for productive professionals.")
`(("alexandria" ,sbcl-alexandria)
("bordeaux-threads" ,sbcl-bordeaux-threads)
("cl-annot" ,sbcl-cl-annot)
+ ("cl-ansi-text" ,sbcl-cl-ansi-text)
("cl-css" ,sbcl-cl-css)
("cl-hooks" ,sbcl-cl-hooks)
("cl-json" ,sbcl-cl-json)
("cl-markup" ,sbcl-cl-markup)
("cl-ppcre" ,sbcl-cl-ppcre)
("cl-ppcre-unicode" ,sbcl-cl-ppcre-unicode)
+ ("cl-prevalence" ,sbcl-cl-prevalence)
("closer-mop" ,sbcl-closer-mop)
("dbus" ,cl-dbus)
("dexador" ,sbcl-dexador)
@@ -523,14 +559,16 @@ features for productive professionals.")
("quri" ,sbcl-quri)
("sqlite" ,sbcl-cl-sqlite)
("str" ,sbcl-cl-str)
- ("swank" ,sbcl-slime-swank)
+ ("swank" ,cl-slime-swank)
("trivia" ,sbcl-trivia)
("trivial-clipboard" ,sbcl-trivial-clipboard)
("unix-opts" ,sbcl-unix-opts)
;; Local deps
("next-gtk-webkit" ,next-gtk-webkit)
("next-download-manager" ,sbcl-next-download-manager)
- ("next-ring" ,sbcl-next-ring)))
+ ("next-ring" ,sbcl-next-ring)
+ ("next-history-tree" ,sbcl-next-history-tree)
+ ("next-password-manager" ,sbcl-next-password-manager)))
(native-inputs
`(("trivial-features" ,sbcl-trivial-features)
("prove-asdf" ,sbcl-prove-asdf)))