summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-11-19 11:20:32 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2021-11-19 11:20:32 +0100
commitbd2aa8031babdca5f574fca52e025d6794f08d82 (patch)
treed19d9d8cd14fad1b5f7012bca3c67cc3784f75e7 /gnu/packages/web-browsers.scm
parent044161025e1d533de57dd380da206fd6db462e66 (diff)
downloadguix-patches-bd2aa8031babdca5f574fca52e025d6794f08d82.tar
guix-patches-bd2aa8031babdca5f574fca52e025d6794f08d82.tar.gz
gnu: nyxt: Update to 2.2.3.
* gnu/packages/web-browsers.scm (nyxt): Update to 2.2.3.
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 3b495b8978..7ea2a9a9ec 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -577,7 +577,7 @@ driven and does not detract you from your daily work.")
(define-public nyxt
(package
(name "nyxt")
- (version "2.2.0")
+ (version "2.2.3")
(source
(origin
(method git-fetch)
@@ -586,11 +586,11 @@ driven and does not detract you from your daily work.")
(commit version)))
(sha256
(base32
- "0l8x32fsvk2gbymcda1yc0ggnsymjazqd58vmi05ifiiv7jwxyjw"))
+ "1v1szbj44pwxh3k70fvg78xjfkab29dqnlafa722sppdyqd06cqp"))
(file-name (git-file-name "nyxt" version))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list "nyxt" "NYXT_INTERNAL_QUICKLISP=false"
+ `(#:make-flags (list "nyxt" "NYXT_SUBMODULES=false"
(string-append "DESTDIR=" (assoc-ref %outputs "out"))
"PREFIX=")
#:strip-binaries? #f ; Stripping breaks SBCL binaries.
@@ -685,9 +685,9 @@ driven and does not detract you from your daily work.")
("gobject-introspection" ,gobject-introspection)))
(synopsis "Extensible web-browser in Common Lisp")
(home-page "https://nyxt.atlas.engineer")
- (description "Nyxt is a keyboard-oriented, extensible web browser designed
-for power users. Conceptually inspired by Emacs and Vim, it has familiar
-key-bindings (Emacs, vi, CUA), and is fully configurable in Common Lisp.")
+ (description "Nyxt is a keyboard-oriented, extensible web-browser designed
+for power users. The application has familiar Emacs and VI key-bindings and
+is fully configurable and extensible in Common Lisp.")
(license license:bsd-3)))
(define-public lagrange