summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-04-13 16:36:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-04-13 16:36:03 +0200
commitb13ef6ee7489b78be7f700489792ea672de13d36 (patch)
tree36ccb42dc688901c6419130479ef851d46addb79 /gnu/packages/web-browsers.scm
parent533a893cc6b03f100566760d6e0c8e0500ed7082 (diff)
parentb5607d830c917c49ca9a7993962bd2b7c7be953c (diff)
downloadguix-patches-b13ef6ee7489b78be7f700489792ea672de13d36.tar
guix-patches-b13ef6ee7489b78be7f700489792ea672de13d36.tar.gz
Merge remote-tracking branch 'upstream/master' into staging
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 52df3f4fbc..a48eb7ead5 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Cage <cage-dev@twistfold.it>
;;; Copyright © 2021 Benoit Joly <benoit@benoitj.ca>
+;;; Copyright © 2021 Alexander Krotov <krotov@iitp.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -65,20 +66,24 @@
#:use-module (gnu packages image)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
+ #:use-module (gnu packages libunistring)
#:use-module (gnu packages linux)
#:use-module (gnu packages lisp)
#:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages lua)
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
+ #:use-module (gnu packages mp3)
#:use-module (gnu packages nano)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages sdl)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tls)
#:use-module (gnu packages webkit)
@@ -718,6 +723,39 @@ key-bindings and is fully configurable and extensible in Common Lisp.")
(define-public sbcl-next
(deprecated-package "sbcl-next" nyxt))
+(define-public lagrange
+ (package
+ (name "lagrange")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://git.skyjake.fi/skyjake/lagrange/releases/"
+ "download/v" version "/lagrange-" version ".tar.gz"))
+ (sha256
+ (base32 "14yj3l3h6i6ygdhyiwdg2cg6y5imlkql09r7dm5v7xm1ja0sr9lp"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #false)) ;no tests
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libunistring" ,libunistring)
+ ("mpg123" ,mpg123)
+ ("openssl" ,openssl)
+ ("pcre" ,pcre)
+ ("sdl2" ,sdl2)
+ ("zlib" ,zlib)))
+ (home-page "https://gmi.skyjake.fi/lagrange/")
+ (synopsis "Graphical Gemini client")
+ (description
+ "Lagrange is a desktop GUI client for browsing Geminispace. It offers
+modern conveniences familiar from web browsers, such as smooth scrolling,
+inline image viewing, multiple tabs, visual themes, Unicode fonts, bookmarks,
+history, and page outlines.")
+ (license license:bsd-2)))
+
(define-public gmni
(let ((commit "d8f0870446c471a42612d6a8e853ad9b723a6d39")
(revision "0"))