summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-10-02 13:11:51 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-02 13:11:51 +0200
commitab0ede51c041927a1c35535aec3504f84d7a9751 (patch)
tree5c21cc3cff68f7255f241823b2acb717e436174d /gnu/packages/web-browsers.scm
parente8ded3ee6af0324fbca067511768be1c3bd1ad66 (diff)
downloadguix-patches-ab0ede51c041927a1c35535aec3504f84d7a9751.tar
guix-patches-ab0ede51c041927a1c35535aec3504f84d7a9751.tar.gz
gnu: next: Update to 1.3.3.
* gnu/packages/web-browsers.scm (next-gtk-webkit): Bump version. (sbcl-next-history-tree): New package. (sbcl-next-password-manager): New package. (next)[inputs]: Add cl-ansi-text, cl-prevalence, sbcl-next-history-tree, sbcl-next-password-manager.
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm44
1 files changed, 41 insertions, 3 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 46b5ea7327..ae63ca6cc5 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -367,7 +367,7 @@ driven and does not detract you from your daily work.")
(define next-gtk-webkit
(package
(name "next-gtk-webkit")
- (version "1.3.2")
+ (version "1.3.3")
(source
(origin
(method git-fetch)
@@ -378,7 +378,7 @@ driven and does not detract you from your daily work.")
(commit version)))
(sha256
(base32
- "0863p6ch4pdrn6b81cx2abis0ld7r2n6x34v3z0ihj3jlfj21yx4"))
+ "0vxjihldvif147l2kjd83kk1wcs4ixgv1yxjnpn3wgg8306pgnlh"))
(file-name (git-file-name "next" version))))
(build-system glib-or-gtk-build-system)
(arguments
@@ -445,6 +445,40 @@ features for productive professionals.")
("prove-asdf" ,sbcl-prove-asdf)))
(synopsis "Infinitely extensible web-browser (ring)")))
+(define sbcl-next-history-tree
+ (package
+ (inherit next-gtk-webkit)
+ (name "sbcl-next-history-tree")
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:tests? #t
+ #:asd-file "next.asd"
+ #:asd-system-name "next/history-tree"))
+ (native-inputs
+ `(("trivial-features" ,sbcl-trivial-features)
+ ("prove-asdf" ,sbcl-prove-asdf)))
+ (synopsis "Infinitely extensible web-browser (history-tree)")))
+
+(define sbcl-next-password-manager
+ (package
+ (inherit next-gtk-webkit)
+ (name "sbcl-next-password-manager")
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:tests? #t
+ #:asd-file "next.asd"
+ #:asd-system-name "next/password-manager"))
+ (inputs
+ `(("bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("cl-annot" ,sbcl-cl-annot)
+ ("cl-ppcre" ,sbcl-cl-ppcre)
+ ("str" ,sbcl-cl-str)
+ ("trivial-clipboard" ,sbcl-trivial-clipboard)))
+ (native-inputs
+ `(("trivial-features" ,sbcl-trivial-features)
+ ("prove-asdf" ,sbcl-prove-asdf)))
+ (synopsis "Infinitely extensible web-browser (password manager)")))
+
(define-public next
(let ((version (package-version next-gtk-webkit)))
(package
@@ -509,12 +543,14 @@ features for productive professionals.")
`(("alexandria" ,sbcl-alexandria)
("bordeaux-threads" ,sbcl-bordeaux-threads)
("cl-annot" ,sbcl-cl-annot)
+ ("cl-ansi-text" ,sbcl-cl-ansi-text)
("cl-css" ,sbcl-cl-css)
("cl-hooks" ,sbcl-cl-hooks)
("cl-json" ,sbcl-cl-json)
("cl-markup" ,sbcl-cl-markup)
("cl-ppcre" ,sbcl-cl-ppcre)
("cl-ppcre-unicode" ,sbcl-cl-ppcre-unicode)
+ ("cl-prevalence" ,sbcl-cl-prevalence)
("closer-mop" ,sbcl-closer-mop)
("dbus" ,cl-dbus)
("dexador" ,sbcl-dexador)
@@ -534,7 +570,9 @@ features for productive professionals.")
;; Local deps
("next-gtk-webkit" ,next-gtk-webkit)
("next-download-manager" ,sbcl-next-download-manager)
- ("next-ring" ,sbcl-next-ring)))
+ ("next-ring" ,sbcl-next-ring)
+ ("next-history-tree" ,sbcl-next-history-tree)
+ ("next-password-manager" ,sbcl-next-password-manager)))
(native-inputs
`(("trivial-features" ,sbcl-trivial-features)
("prove-asdf" ,sbcl-prove-asdf)))