summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
commit9bc0f45df5d6aed217020b1183dca54989844fb0 (patch)
treed927e89949ff7f65b5059bc94273c53fd43d0763 /gnu/packages/web-browsers.scm
parent6db3c536e89deb8a204e756f427614925a7d2582 (diff)
parent10554e0a57feeea470127a1d0441957d1776b0bd (diff)
downloadguix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar
guix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm64
1 files changed, 52 insertions, 12 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 5ca68e0ee4..a3457cb62f 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -818,7 +818,7 @@ http, and https via third-party applications.")
(define-public tinmop
(package
(name "tinmop")
- (version "0.8.3")
+ (version "0.9.2")
(source
(origin
(method git-fetch)
@@ -827,13 +827,17 @@ http, and https via third-party applications.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "117p1wxi5swmqw429qrswxz2zvp1dcaw2145gk6zxlgwln48qxl8"))))
+ (base32 "1cgx2g2kryfmcwqzzjzcpbdc6zzj10xc52gz0cj2dx5ylc0yg7k3"))))
(build-system gnu-build-system)
(native-inputs
- `(("curl" ,curl)
+ `(("automake" ,automake)
+ ("autoreconf" ,autoconf)
("gettext" ,gnu-gettext)
- ("gnupg" ,gnupg)
- ("sbcl" ,sbcl)))
+ ("mandoc" , mandoc)
+ ("nano" ,nano)
+ ("openssl" ,openssl)
+ ("sbcl" ,sbcl)
+ ("xdg-utils" ,xdg-utils)))
(inputs
`(("access" ,sbcl-access)
("alexandria" ,sbcl-alexandria)
@@ -856,8 +860,6 @@ http, and https via third-party applications.")
("local-time" ,sbcl-local-time)
("log4cl" ,sbcl-log4cl)
("marshal" ,sbcl-marshal)
- ("nano" ,nano)
- ("openssl" ,openssl)
("osicat" ,sbcl-osicat)
("parse-number" ,sbcl-parse-number)
("percent-encoding" ,sbcl-percent-encoding)
@@ -865,8 +867,7 @@ http, and https via third-party applications.")
("sxql-composer" ,sbcl-sxql-composer)
("tooter" ,sbcl-tooter)
("unix-opts" ,sbcl-unix-opts)
- ("usocket" ,sbcl-usocket)
- ("xdg-utils" ,xdg-utils)))
+ ("usocket" ,sbcl-usocket)))
(arguments
`(#:tests? #f
#:strip-binaries? #f
@@ -876,11 +877,24 @@ http, and https via third-party applications.")
(lambda _
(setenv "HOME" "/tmp")
#t))
+ (add-after 'unpack 'fix-configure.ac
+ (lambda _
+ (delete-file "configure")
+ (substitute* "configure.ac"
+ (("AC_PATH_PROG.+CURL")
+ "dnl")
+ (("AC_PATH_PROGS.+GIT")
+ "dnl")
+ (("AC_PATH_PROG.+GPG")
+ "dnl"))
+ #t))
(add-after 'configure 'fix-asdf
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makefile.in"
(("LISP_COMPILER) ")
- "LISP_COMPILER) --eval \"(require 'asdf)\" --eval \"(push \\\"$$(pwd)/\\\" asdf:*central-registry*)\" "))
+ (string-concatenate
+ '("LISP_COMPILER) --eval \"(require 'asdf)\" "
+ "--eval \"(push \\\"$$(pwd)/\\\" asdf:*central-registry*)\" "))))
#t)))))
(synopsis "Gemini and pleroma client with a terminal interface")
(description
@@ -892,14 +906,14 @@ interface.")
(define-public telescope
(package
(name "telescope")
- (version "0.5.2")
+ (version "0.6.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/omar-polo/telescope/releases/download/"
version "/telescope-" version ".tar.gz"))
(sha256
- (base32 "0phvwhxvm63y68cyvzw5dk60yjzfv6bpxf5c4bl08daj3ia48fbk"))))
+ (base32 "1hm9gi6yz62h8yh2br85bgycr2xaf5lr7z4gl0p25g7d7qb53ixd"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f)) ;no tests
@@ -915,6 +929,32 @@ interface.")
(description "Telescope is a w3m-like browser for Gemini.")
(license license:x11)))
+(define-public leo
+ ;; PyPi only provides a wheel.
+ (let ((commit "88cc10a87afe2ec86be06e6ea2bcd099f5360b74")
+ (version "1.0.4")
+ (revision "1"))
+ (package
+ (name "leo")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xyzshantaram/leo")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jp4v4jw82qqynqqs7x35g5yvm1sd48cvbqh7j2r1ixw1z6ldhc4"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/xyzshantaram/leo")
+ (synopsis "Gemini client written in Python")
+ (description
+ "@command{leo} is a gemini client written in Python with no external
+dependencies that fully implements the Gemini spec. A list of URLs can be
+saved to a file for further viewing in another window.")
+ (license license:expat))))
+
(define-public av-98
(package
(name "av-98")