summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorB. Wilson <elaexuotee@wilsonb.com>2020-05-13 13:51:19 +0900
committerEfraim Flashner <efraim@flashner.co.il>2020-05-17 16:47:47 +0300
commit5b4db51638d3fc828a59890ccb9b3f2e306a147e (patch)
tree00c4c09c8b8242298851ad9910468e25645e2081 /gnu/packages/web-browsers.scm
parentebbf91542269fcb36d64928d4a4992e6afbf2acf (diff)
downloadguix-patches-5b4db51638d3fc828a59890ccb9b3f2e306a147e.tar
guix-patches-5b4db51638d3fc828a59890ccb9b3f2e306a147e.tar.gz
gnu: Add bombadillo.
gnu/packages/web-browsers.scm (bombadillo): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm47
1 files changed, 46 insertions, 1 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 62b7a5bdca..b61ed7f3ca 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2019 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
+;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -66,7 +67,8 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
- #:use-module (guix build-system asdf))
+ #:use-module (guix build-system asdf)
+ #:use-module (guix build-system go))
(define-public midori
(package
@@ -692,3 +694,46 @@ key-bindings and is fully configurable and extensible in Common Lisp.")
(define-public sbcl-next
(deprecated-package "sbcl-next" next))
+
+(define-public bombadillo
+ (package
+ (name "bombadillo")
+ (version "2.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://tildegit.org/sloum/bombadillo")
+ (commit version)))
+ (sha256
+ (base32
+ "1m52b1wk48gkqmjy8l0x3jaksrx2v8w6w59lhr7zaw2i0n4f5k0z"))
+ (file-name (git-file-name name version))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "tildegit.org/sloum/bombadillo"
+ #:install-source? #f
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'install-data
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((builddir "src/tildegit.org/sloum/bombadillo")
+ (out (assoc-ref outputs "out"))
+ (pkg (strip-store-file-name out))
+ (sharedir (string-append out "/share"))
+ (appdir (string-append sharedir "/applications"))
+ (docdir (string-append sharedir "/doc/" pkg))
+ (mandir (string-append sharedir "/man/man1"))
+ (pixdir (string-append sharedir "/pixmaps")))
+ (with-directory-excursion builddir
+ (install-file "bombadillo.desktop" appdir)
+ (install-file "LICENSE" docdir)
+ (install-file "bombadillo.1" mandir)
+ (install-file "bombadillo-icon.png" pixdir)
+ #t)))))))
+ (home-page "http://bombadillo.colorfield.space")
+ (synopsis "Terminal browser for the gopher, gemini, and finger protocols")
+ (description "Bombadillo is a non-web browser for the terminal with
+vim-like key bindings, a document pager, configurable settings, and robust
+command selection. The following protocols are supported as first-class
+citizens: gopher, gemini, finger, and local. There is also support for telnet,
+http, and https via third-party applications.")
+ (license license:gpl3+)))