summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-05-06 13:41:30 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2021-05-06 13:43:05 +0200
commit39174fd7a7b76dd668e83439156a4478f151b1b7 (patch)
treeed0d0e57804f3fba49d92a94f6cca72d4c115618 /gnu/packages/web-browsers.scm
parent69c749d2ee5bf177fad30fff9ecbb3d8c15e0968 (diff)
downloadguix-patches-39174fd7a7b76dd668e83439156a4478f151b1b7.tar
guix-patches-39174fd7a7b76dd668e83439156a4478f151b1b7.tar.gz
gnu: nyxt: Update to 2-pre-release-7.
* gnu/packages/web-browsers.scm (nyxt): Update to 2-pre-release-7. [arguments]: Set GI_TYPELIB_PATH to the value in the build environment, not just gsettings-desktop-schemas since we also need the typelibs of GTK, Pango, etc. [inputs]: Add sbcl-cl-gobject-introspection, gtk+, webkitgtk, gobjectintrospection. There are all needed for the new GI-based renderer.
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 2457a1c470..6b6ca78960 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -601,7 +601,7 @@ driven and does not detract you from your daily work.")
(name "nyxt")
;; Package the pre-release because latest stable 1.5.0 does not build
;; anymore.
- (version "2-pre-release-6")
+ (version "2-pre-release-7")
(source
(origin
(method git-fetch)
@@ -612,7 +612,7 @@ driven and does not detract you from your daily work.")
(commit version)))
(sha256
(base32
- "0kcqp3p070i6x2jj27h8pxzvmhrzsl4kl3vkc8m76abkxc9lvn03"))
+ "0d5mawka26gwi9nb45x1n33vgskwyn46jrvfz7nzmm2jfaq4ipn6"))
(file-name (git-file-name "nyxt" version))))
(build-system gnu-build-system)
(arguments
@@ -646,12 +646,7 @@ driven and does not detract you from your daily work.")
(string-append (assoc-ref inputs lib) "/lib"))
libs)
":"))
- (gi-path (string-join
- (map (lambda (lib)
- (string-append (assoc-ref inputs lib)
- "/lib/girepository-1.0"))
- libs)
- ":"))
+ (gi-path (getenv "GI_TYPELIB_PATH"))
(xdg-path (string-join
(map (lambda (lib)
(string-append (assoc-ref inputs lib) "/share"))
@@ -708,7 +703,12 @@ driven and does not detract you from your daily work.")
("cl-cffi-gtk" ,sbcl-cl-cffi-gtk)
("cl-webkit" ,sbcl-cl-webkit)
("glib-networking" ,glib-networking)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ;; GObjectIntrospection
+ ("cl-gobject-introspection" ,sbcl-cl-gobject-introspection)
+ ("gtk" ,gtk+) ; For the main loop.
+ ("webkitgtk" ,webkitgtk) ; Required when we use its typelib.
+ ("gobject-introspection" ,gobject-introspection)))
(synopsis "Extensible web-browser in Common Lisp")
(home-page "https://nyxt.atlas.engineer")
(description "Nyxt is a keyboard-oriented, extensible web-browser