summaryrefslogtreecommitdiff
path: root/gnu/packages/w3m.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-07 00:02:40 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-11 07:04:21 -0500
commitfc17dd9eba32455d61e1518000e846a16aa4201a (patch)
treecc90a2dccceff485303b5ef859289677191f7395 /gnu/packages/w3m.scm
parent28fab296685664b5f151e6e4138d63c67bdad88c (diff)
downloadguix-patches-fc17dd9eba32455d61e1518000e846a16aa4201a.tar
guix-patches-fc17dd9eba32455d61e1518000e846a16aa4201a.tar.gz
gnu: w3m: Update to 0.5.3+git20210102.
* gnu/packages/w3m.scm (w3m): Update to 0.5.3+git20210102. [configure-flags]: Add the "--with-imagelib=imlib2" option. [inputs]: Add imlib2.
Diffstat (limited to 'gnu/packages/w3m.scm')
-rw-r--r--gnu/packages/w3m.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/w3m.scm b/gnu/packages/w3m.scm
index 934a6d9e38..a14ca02e84 100644
--- a/gnu/packages/w3m.scm
+++ b/gnu/packages/w3m.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,6 +28,7 @@
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages compression)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -40,7 +42,7 @@
(define-public w3m
(package
(name "w3m")
- (version "0.5.3+git20200502")
+ (version "0.5.3+git20210102")
(source (origin
(method git-fetch)
;; Debian's fork of w3m is the only one that is still maintained.
@@ -50,21 +52,22 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0yyfhwcwy1dvdbirj6zqwk4gl8z9npfavs0k7ipcg5fd16vnx7mi"))))
+ "0amq1wfjp5mhqjmvrc0yhxjlx1335p78d7ap8iykfjn5h8yhmrg5"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no check target
;; Use $EDITOR instead of a hard-coded value.
- #:configure-flags '("--with-editor=")
+ #:configure-flags (list "--with-editor="
+ "--with-imagelib=imlib2")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'fix-perl
(lambda _ (substitute* '("scripts/w3mmail.cgi.in"
"scripts/dirlist.cgi.in")
- (("@PERL@") (which "perl")))
- #t)))))
+ (("@PERL@") (which "perl"))))))))
(inputs
`(("gdk-pixbuf" ,gdk-pixbuf)
+ ("imlib2" ,imlib2)
("libgc" ,libgc)
("libx11" ,libx11)
("ncurses" ,ncurses)