summaryrefslogtreecommitdiff
path: root/gnu/packages/w3m.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-01-05 19:26:25 -0500
committerLeo Famulari <leo@famulari.name>2016-01-07 02:35:38 -0500
commit62339e2d493bf87a3aabe12e45458581e9705d83 (patch)
tree31a9bd122f8827aa2cf349d87ea040bb5cca5b9e /gnu/packages/w3m.scm
parente6352001c444a82141ea4457e49e69a1c3f8b2bb (diff)
downloadguix-patches-62339e2d493bf87a3aabe12e45458581e9705d83.tar
guix-patches-62339e2d493bf87a3aabe12e45458581e9705d83.tar.gz
gnu: w3m: Enable SSL, disable broken protocols and ciphers.
Fixes <http://bugs.gnu.org/16791>. * gnu/packages/patches/w3m-force-ssl_verify_server-on.patch: New file. * gnu/packages/patches/w3m-disable-sslv2-and-sslv3.patch: New file. * gnu/packages/patches/w3m-disable-weak-ciphers.patch: New file. * gnu/packages/w3m.scm (w3m)[source]: Add patches. * gnu-system.am (dist_patch_DATA): Add the new files.
Diffstat (limited to 'gnu/packages/w3m.scm')
-rw-r--r--gnu/packages/w3m.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/w3m.scm b/gnu/packages/w3m.scm
index 113bfc484c..45c9375def 100644
--- a/gnu/packages/w3m.scm
+++ b/gnu/packages/w3m.scm
@@ -44,7 +44,10 @@
"1qx9f0kprf92r1wxl3sacykla0g04qsi0idypzz24b7xy9ix5579"))
;; cf. https://bugs.archlinux.org/task/33397
- (patches (list (search-patch "w3m-libgc.patch")))))
+ (patches (list (search-patch "w3m-libgc.patch")
+ (search-patch "w3m-force-ssl_verify_server-on.patch")
+ (search-patch "w3m-disable-sslv2-and-sslv3.patch")
+ (search-patch "w3m-disable-weak-ciphers.patch")))))
(build-system gnu-build-system)
(arguments `(#:tests? #f ; no check target
#:phases (alist-cons-before