summaryrefslogtreecommitdiff
path: root/gnu/packages/w3m.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-06-03 12:57:52 +0200
committerRutger Helling <rhelling@mykolab.com>2018-06-03 13:01:41 +0200
commit4edc431b0f1a8893e950a3ee6c2fdebe9d5a6f7a (patch)
tree7f8a255c63286b8ce079ab21a6db17243d78d045 /gnu/packages/w3m.scm
parent6f5c67d7250913bde52f47904fda08325a9334a3 (diff)
downloadguix-patches-4edc431b0f1a8893e950a3ee6c2fdebe9d5a6f7a.tar
guix-patches-4edc431b0f1a8893e950a3ee6c2fdebe9d5a6f7a.tar.gz
gnu: w3m: Enable image support.
* gnu/packages/w3m.scm (w3m)[inputs]: Add gdk-pixbuf, libx11.
Diffstat (limited to 'gnu/packages/w3m.scm')
-rw-r--r--gnu/packages/w3m.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/w3m.scm b/gnu/packages/w3m.scm
index db23b4d8df..4e3264a47e 100644
--- a/gnu/packages/w3m.scm
+++ b/gnu/packages/w3m.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016, 2017, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,10 +25,12 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages xorg)
#:use-module (gnu packages)
#:use-module (guix packages)
#:use-module (guix git-download)
@@ -61,7 +64,9 @@
(("@PERL@") (which "perl")))
#t)))))
(inputs
- `(("libgc" ,libgc)
+ `(("gdk-pixbuf" ,gdk-pixbuf)
+ ("libgc" ,libgc)
+ ("libx11" ,libx11)
("ncurses" ,ncurses)
("openssl" ,openssl)
("zlib" ,zlib)))