summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
authorVitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>2020-04-08 02:28:20 +0700
committerGuix Patches Tester <>2020-04-07 22:26:15 +0100
commitf85a41de16cdbb35c998ed258326275d1ff6cbe5 (patch)
treebce41d8887f4626319d19a9b20052cb9eebb98ed /gnu/packages/vulkan.scm
parent1c86577d624b97a03138640b4d849823b504570e (diff)
downloadguix-patches-f85a41de16cdbb35c998ed258326275d1ff6cbe5.tar
guix-patches-f85a41de16cdbb35c998ed258326275d1ff6cbe5.tar.gz
gnu: Add taisei, and spirv-cross
* gnu/packages/games.scm (taisei): new variable * gnu/packages/vulkan.scm (spirv-cross): new variable
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 6a2c219aac..e0a031141f 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -107,6 +107,37 @@ SPIR-V modules. The project includes an assembler, binary module
parser,disassembler, validator, and optimizer for SPIR-V.")
(license license:asl2.0)))
+(define-public spirv-cross
+ (package
+ (name "spirv-cross")
+ (version "2020-04-03")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KhronosGroup/SPIRV-Cross")
+ (commit (string-append version))))
+ (sha256
+ (base32 "0489s29kqgq20clxqg22y299yxz23p0yjh87yhka705hm9skx4sa"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments ;TODO: solve "No tests were found!!!"
+ `(#:configure-flags
+ (list "-DSPIRV_CROSS_SHARED=YES")))
+ (inputs `(("spirv-headers" ,spirv-headers)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (home-page "https://github.com/KhronosGroup/SPIRV-Cross")
+ (synopsis "Parser for and converter of SPIR-V to other shader languages")
+ (description
+ "SPIRV-Cross tries hard to emit readable and clean output from the
+SPIR-V. The goal is to emit GLSL or MSL that looks like it was written by a
+human and not awkward IR/assembly-like code. NOTE: Individual features are
+expected to be mostly complete, but it is possible that certain obscure GLSL
+features are not yet supported. However, most missing features are expected
+to be \"trivial\" improvements at this stage.")
+ (license license:asl2.0)))
+
(define-public glslang
(package
(name "glslang")