summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-03-06 09:43:32 +0100
committerRutger Helling <rhelling@mykolab.com>2019-03-06 09:47:13 +0100
commite21bd8dff8e85635ef96c4bf043dda6539f604cd (patch)
tree0f38a4eeea1ee6751f99e7016f0a0c6aa239a90d /gnu/packages/vulkan.scm
parent6d3cff5acacecc240b1d86048e41df3ce26483a5 (diff)
downloadguix-patches-e21bd8dff8e85635ef96c4bf043dda6539f604cd.tar
guix-patches-e21bd8dff8e85635ef96c4bf043dda6539f604cd.tar.gz
gnu: vulkan-headers: Update to 1.1.102.
* gnu/packages/vulkan.scm (vulkan-headers): Update to 1.1.102. * gnu/packages/vulkan.scm (vulkan-loader): Update hash. * gnu/packages/vulkan.scm (vulkan-tools): Update to 1.1.101. [arguments]: Add "-DBUILD_ICD=off" and "-DGLSLANG_INSTALL_DIR=" configure flags.
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index d4b8b7a691..cdbac2f35c 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -163,7 +163,7 @@ interpretation of the specifications for these languages.")
(define-public vulkan-headers
(package
(name "vulkan-headers")
- (version "1.1.101")
+ (version "1.1.102")
(source
(origin
(method git-fetch)
@@ -173,7 +173,7 @@ interpretation of the specifications for these languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "1hb1lg56i2685nz7i4hbsv3sz1iym2wimjz4bfa175xh5jyvr0km"))))
+ "1dkjg48l7dfpq16bq1w9c3y9dwpj2hhv7b3njvj52lpgpa14s0f9"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; No tests.
@@ -197,7 +197,7 @@ interpretation of the specifications for these languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "02xkjaack3zmbsnh95jbkkdarf7ccfpfjby12kikajwr0kr4d4df"))))
+ "0ccpklv251jcz2lxvd5ix5i3cg4wb7qq5xi6cwvniy1rw52z7h00"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;FIXME: 23/39 tests fail. Try "tests/run_all_tests.sh".
@@ -244,7 +244,7 @@ and the ICD.")
(define-public vulkan-tools
(package
(name "vulkan-tools")
- (version "1.1.100")
+ (version "1.1.101")
(source
(origin
(method git-fetch)
@@ -254,7 +254,7 @@ and the ICD.")
(file-name (git-file-name name version))
(sha256
(base32
- "1b9c8yimn34b77nbrkra4qj71gcw8zr0cgdp85ghxampm7gzx0xi"))))
+ "0qms8xjl0i9ajrckxkcq7rj28zjby4gbr1vz8xxkmgfbani8mai4"))))
(build-system cmake-build-system)
(inputs
`(("glslang" ,glslang)
@@ -267,7 +267,10 @@ and the ICD.")
`(("pkg-config" ,pkg-config)
("python" ,python)))
(arguments
- `(#:tests? #f)) ; No tests.
+ `(#:tests? #f ; No tests.
+ #:configure-flags (list "-DBUILD_ICD=off" ; FIXME: Doesn't build.
+ (string-append "-DGLSLANG_INSTALL_DIR="
+ (assoc-ref %build-inputs "glslang")))))
(home-page
"https://github.com/KhronosGroup/Vulkan-Tools")
(synopsis "Tools and utilities for Vulkan")