summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-03-07 10:40:26 +0100
committerRutger Helling <rhelling@mykolab.com>2019-03-07 10:42:27 +0100
commit97764172467baa3cbecd016a81913060972e0839 (patch)
treed5335a15807b4bacbb70cf59e7e3983350c7c28c /gnu/packages/vulkan.scm
parent7e0f4cb154428a9e1df50936653a3250717257aa (diff)
downloadguix-patches-97764172467baa3cbecd016a81913060972e0839.tar
guix-patches-97764172467baa3cbecd016a81913060972e0839.tar.gz
gnu: vulkan-tools: Update to 1.1.102.
* gnu/packages/vulkan.scm (vulkan-tools): Update to 1.1.102. [arguments]: Remove "-DBUILD_ICD=OFF" configure flag.
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 787b4a388a..98a0523ee7 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -244,7 +244,7 @@ and the ICD.")
(define-public vulkan-tools
(package
(name "vulkan-tools")
- (version "1.1.101")
+ (version (package-version vulkan-headers))
(source
(origin
(method git-fetch)
@@ -254,7 +254,7 @@ and the ICD.")
(file-name (git-file-name name version))
(sha256
(base32
- "0qms8xjl0i9ajrckxkcq7rj28zjby4gbr1vz8xxkmgfbani8mai4"))))
+ "0a8vmgyn7an21bb9vxba9laf9ghvk905vn7rm8frdl8qr2b7vyw3"))))
(build-system cmake-build-system)
(inputs
`(("glslang" ,glslang)
@@ -268,8 +268,7 @@ and the ICD.")
("python" ,python)))
(arguments
`(#:tests? #f ; No tests.
- #:configure-flags (list "-DBUILD_ICD=off" ; FIXME: Doesn't build.
- (string-append "-DGLSLANG_INSTALL_DIR="
+ #:configure-flags (list (string-append "-DGLSLANG_INSTALL_DIR="
(assoc-ref %build-inputs "glslang")))))
(home-page
"https://github.com/KhronosGroup/Vulkan-Tools")