summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-04-23 10:55:59 +0200
committerRutger Helling <rhelling@mykolab.com>2019-04-23 11:03:56 +0200
commit93c5c6d1648570a66c34e41470ef6dde98317f0c (patch)
treeb8a976f153f08990f424dc26b13368434c69a336 /gnu/packages/vulkan.scm
parentb2e417f3f11578f30a7635300cf338f96c15d981 (diff)
downloadguix-patches-93c5c6d1648570a66c34e41470ef6dde98317f0c.tar
guix-patches-93c5c6d1648570a66c34e41470ef6dde98317f0c.tar.gz
gnu: spirv-headers: Update to 1.3.7.
* gnu/packages/vulkan.scm (spirv-headers): Update to 1.3.7.
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm64
1 files changed, 30 insertions, 34 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 996b6cdd49..543b77f7d4 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -41,37 +41,33 @@
#:use-module (gnu packages xorg))
(define-public spirv-headers
- ;; Keep updated in accordance with
- ;; https://github.com/google/shaderc/blob/known-good/known_good.json
- (let ((commit "8bea0a266ac9b718aa0818d9e3a47c0b77c2cb23")
- (revision "4"))
- (package
- (name "spirv-headers")
- (version (string-append "0.0-" revision "." (string-take commit 9)))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/KhronosGroup/SPIRV-Headers")
- (commit commit)))
- (sha256
- (base32
- "01qyjghjz42hmyw9111zz20a1paf37ps39p4xbj8abjba65d8lqx"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ;; No tests
- #:phases (modify-phases %standard-phases
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "cmake" "-E" "copy_directory"
- "../source/include/spirv"
- (string-append (assoc-ref outputs "out")
- "/include/spirv")))))))
- (home-page "https://github.com/KhronosGroup/SPIRV-Headers")
- (synopsis "Machine-readable files from the SPIR-V Registry")
- (description
- "SPIRV-Headers is a repository containing machine-readable files from
+ (package
+ (name "spirv-headers")
+ (version "1.3.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KhronosGroup/SPIRV-Headers")
+ (commit version)))
+ (sha256
+ (base32
+ "0m56smanfcczjfif4yfcqhjj4d4sc088kwg6dgia8fwdsjavdm4d"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;; No tests
+ #:phases (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "cmake" "-E" "copy_directory"
+ "../source/include/spirv"
+ (string-append (assoc-ref outputs "out")
+ "/include/spirv")))))))
+ (home-page "https://github.com/KhronosGroup/SPIRV-Headers")
+ (synopsis "Machine-readable files from the SPIR-V Registry")
+ (description
+ "SPIRV-Headers is a repository containing machine-readable files from
the SPIR-V Registry. This includes:
@itemize
@item Header files for various languages.
@@ -79,9 +75,9 @@ the SPIR-V Registry. This includes:
and for the GLSL.std.450 extended instruction set.
@item The XML registry file.
@end itemize\n")
- (license (license:x11-style
- (string-append "https://github.com/KhronosGroup/SPIRV-Headers/blob/"
- commit "/LICENSE"))))))
+ (license (license:x11-style
+ (string-append "https://github.com/KhronosGroup/SPIRV-Headers/blob/"
+ version "/LICENSE")))))
(define-public spirv-tools
(package