summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-01-31 14:20:57 +0100
committerRutger Helling <rhelling@mykolab.com>2018-01-31 14:26:40 +0100
commit76ef53eb8287b27a970da58372f6c442fa18e1ed (patch)
tree59d431a3b65c19fd49072fb8e2a68891355ad312 /gnu/packages/vulkan.scm
parenta9342820d32e1dfcf6cd5834356ccefdca41aae0 (diff)
downloadguix-patches-76ef53eb8287b27a970da58372f6c442fa18e1ed.tar
guix-patches-76ef53eb8287b27a970da58372f6c442fa18e1ed.tar.gz
gnu: glslang: Update to commit b5b08462442239e6537315ea1405b6afcd53043e.
* gnu/packages/vulkan.scm (glslang): Update to commit b5b08462442239e6537315ea1405b6afcd53043e.
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 81e5d1f2a0..183d42fab5 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -111,10 +111,10 @@ disassembler, validator, and optimizer for SPIR-V.")
(license license:asl2.0))))
(define-public glslang
- ;; Version 3.0 is too old for vulkan-icd-loader. Use a recent git commit
- ;; until the next stable version.
- (let ((commit "471bfed0621162a7513fc24a51e8a1ccc2e640ff")
- (revision "1"))
+ ;; Keep updated in accordance with
+ ;; https://github.com/google/shaderc/blob/known-good/known_good.json
+ (let ((commit "b5b08462442239e6537315ea1405b6afcd53043e")
+ (revision "2"))
(package
(name "glslang")
(version (string-append "3.0-" revision "." (string-take commit 9)))
@@ -126,7 +126,7 @@ disassembler, validator, and optimizer for SPIR-V.")
(commit commit)))
(sha256
(base32
- "0m2vljmrqppp80ghbbwfnayqw2canxlcjhgy6jw9xjdssln0d3pd"))
+ "08imby3hciisshzacrkx8s56lx4fxm7dad06xxaxxcapinmqrvwk"))
(file-name (string-append name "-" version "-checkout"))))
(build-system cmake-build-system)
(arguments