summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-02 20:18:16 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-02 20:18:16 +0200
commit4fb916551579d336ebea0dbe968314febb3a99d4 (patch)
tree2e101d05ece8408869e6dcad387efb39717f5726 /gnu/packages/vulkan.scm
parent6661b025a6c58be6572fc66c5db1073f56af30b0 (diff)
parent30484be05d9e318e89e12f40a55c65766cec700a (diff)
downloadguix-patches-4fb916551579d336ebea0dbe968314febb3a99d4.tar
guix-patches-4fb916551579d336ebea0dbe968314febb3a99d4.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm30
1 files changed, 26 insertions, 4 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 6ae9ba9b87..c16535f704 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -159,7 +159,7 @@ interpretation of the specifications for these languages.")
(define-public vulkan-headers
(package
(name "vulkan-headers")
- (version "1.1.107")
+ (version "1.1.112")
(source
(origin
(method git-fetch)
@@ -169,7 +169,7 @@ interpretation of the specifications for these languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "0kyf83n6fghqmjj5jbwhy08yq5sl598qnmw3kbavrnw9avqqm0c4"))))
+ "0iia2wlq38hvxwip6r3k5946ylrlk42fw50mhf0pdjxjh02p8zn5"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; No tests.
@@ -193,7 +193,7 @@ interpretation of the specifications for these languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "1p64k9x5r7nsrs0cn6d61687xbajqvsm78xk6j85w9wfin5dxs30"))))
+ "1819bgmpjlikcc25bkmwwb7mp1rlyrq2v74wybg1g40ix70v0m0d"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;FIXME: 23/39 tests fail. Try "tests/run_all_tests.sh".
@@ -203,6 +203,28 @@ interpretation of the specifications for these languages.")
(lambda* (#:key inputs #:allow-other-keys)
;; Remove lines trying to build in a git commit id.
(substitute* "CMakeLists.txt" ((".*spirv_tools_commit_id.h.*") ""))
+ #t))
+ ;; Make sure that the files needed for Mesa's Vulkan overlay are availabe.
+ (add-after 'unpack 'copy-headers1
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "tests/layers/vk_layer_data.h"
+ (string-append (assoc-ref %outputs "out")
+ "/include/vulkan"))
+ (install-file "tests/layers/vk_layer_extension_utils.h"
+ (string-append (assoc-ref %outputs "out")
+ "/include/vulkan"))
+ (install-file "loader/vk_loader_platform.h"
+ (string-append (assoc-ref %outputs "out")
+ "/include/vulkan"))
+ #t))
+ (add-after 'build 'copy-headers2
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "vk_layer_dispatch_table.h"
+ (string-append (assoc-ref %outputs "out")
+ "/include/vulkan"))
+ (install-file "vk_dispatch_table_helper.h"
+ (string-append (assoc-ref %outputs "out")
+ "/include/vulkan"))
#t)))
#:configure-flags (list
"-DBUILD_TESTS=OFF" ; FIXME: Needs 'googletest' submodule.
@@ -244,7 +266,7 @@ and the ICD.")
(file-name (git-file-name name version))
(sha256
(base32
- "1mak96jdg3wv043b4jxyv1fm2cz4nnallg0yb90my3yp5q64grrw"))))
+ "0an9hqvvpfmfld2pkszzwi7ccb9g2ijjqqzlj24dqg9kqnmcr3x4"))))
(build-system cmake-build-system)
(inputs
`(("glslang" ,glslang)