summaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-23 19:43:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-23 19:43:59 +0200
commit37da4fbe1562583589eeddb4be8e11bece80fd35 (patch)
tree4d8a454b27e62f9b8d7b0fe641a9f6aa6de2402c /gnu/packages/vulkan.scm
parent73326e742d82b6706333885eca770f7518636b1f (diff)
parente01bd1a67447c1f2a2b5b03e8ea8fbbccd2cd5bd (diff)
downloadguix-patches-37da4fbe1562583589eeddb4be8e11bece80fd35.tar
guix-patches-37da4fbe1562583589eeddb4be8e11bece80fd35.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm68
1 files changed, 32 insertions, 36 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index cd77211377..60a9661040 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -41,37 +41,33 @@
#:use-module (gnu packages xorg))
(define-public spirv-headers
- ;; Keep updated in accordance with
- ;; https://github.com/google/shaderc/blob/known-good/known_good.json
- (let ((commit "8bea0a266ac9b718aa0818d9e3a47c0b77c2cb23")
- (revision "4"))
- (package
- (name "spirv-headers")
- (version (string-append "0.0-" revision "." (string-take commit 9)))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/KhronosGroup/SPIRV-Headers")
- (commit commit)))
- (sha256
- (base32
- "01qyjghjz42hmyw9111zz20a1paf37ps39p4xbj8abjba65d8lqx"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ;; No tests
- #:phases (modify-phases %standard-phases
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "cmake" "-E" "copy_directory"
- "../source/include/spirv"
- (string-append (assoc-ref outputs "out")
- "/include/spirv")))))))
- (home-page "https://github.com/KhronosGroup/SPIRV-Headers")
- (synopsis "Machine-readable files from the SPIR-V Registry")
- (description
- "SPIRV-Headers is a repository containing machine-readable files from
+ (package
+ (name "spirv-headers")
+ (version "1.3.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KhronosGroup/SPIRV-Headers")
+ (commit version)))
+ (sha256
+ (base32
+ "0m56smanfcczjfif4yfcqhjj4d4sc088kwg6dgia8fwdsjavdm4d"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;; No tests
+ #:phases (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "cmake" "-E" "copy_directory"
+ "../source/include/spirv"
+ (string-append (assoc-ref outputs "out")
+ "/include/spirv")))))))
+ (home-page "https://github.com/KhronosGroup/SPIRV-Headers")
+ (synopsis "Machine-readable files from the SPIR-V Registry")
+ (description
+ "SPIRV-Headers is a repository containing machine-readable files from
the SPIR-V Registry. This includes:
@itemize
@item Header files for various languages.
@@ -79,9 +75,9 @@ the SPIR-V Registry. This includes:
and for the GLSL.std.450 extended instruction set.
@item The XML registry file.
@end itemize\n")
- (license (license:x11-style
- (string-append "https://github.com/KhronosGroup/SPIRV-Headers/blob/"
- commit "/LICENSE"))))))
+ (license (license:x11-style
+ (string-append "https://github.com/KhronosGroup/SPIRV-Headers/blob/"
+ version "/LICENSE")))))
(define-public spirv-tools
(package
@@ -124,7 +120,7 @@ parser,disassembler, validator, and optimizer for SPIR-V.")
(define-public glslang
(package
(name "glslang")
- (version "7.11.3113")
+ (version "7.11.3188")
(source
(origin
(method git-fetch)
@@ -133,7 +129,7 @@ parser,disassembler, validator, and optimizer for SPIR-V.")
(commit version)))
(sha256
(base32
- "1kzv2b4q1fddxd7c0hc754nd6rw6y9vijb9fsi13xzzq9dficgb6"))
+ "04y4dd1cqdkd4qffmhgmg3agf9j07ii2w38vpp4jw53ir818bqdq"))
(file-name (string-append name "-" version "-checkout"))))
(build-system cmake-build-system)
(arguments