summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-19 16:03:09 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:01 -0400
commitd45727f4e4be401cbed6c49614e242ffc0a5c581 (patch)
tree6f08d136c227b00b5ef669dd5f389d17059c65d2 /gnu/packages/vpn.scm
parent10ea06342a2e57ba6db39dd2e51e8d4e37cae5bb (diff)
downloadguix-patches-d45727f4e4be401cbed6c49614e242ffc0a5c581.tar
guix-patches-d45727f4e4be401cbed6c49614e242ffc0a5c581.tar.gz
gnu: sshoot: Update to 1.5.1.
* gnu/packages/vpn.scm (sshoot): Update to 1.5.1. [phases]: Delete trailing #t. {check}: Override phase. [inputs]: Add python-pyxdg and python-toolrack. [native-inputs]: Delete python-fixtures, python-pbr and python-testtools. Add python-pytest and python-pytest-mock.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 5bf5a62481..f3da89675e 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2022 Josselin Poiret <josselin.poiret@protonmail.ch>
;;; Copyright © 2022 Lu hui <luhux76@gmail.com>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -907,14 +908,14 @@ DNS domain name queries.")
(define-public sshoot
(package
(name "sshoot")
- (version "1.2.6")
+ (version "1.5.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri name version))
(sha256
(base32
- "1ccgh0hjyxrwkgy3hnxz3hgbjbs0lmfs25d5l5jam0xbpcpj63h0"))))
+ "05i54nga4vy660yy9yf6dl376yj0jc51303yr295qk3k9w0k96yd"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -922,13 +923,20 @@ DNS domain name queries.")
(add-after 'unpack 'patch-paths
(lambda _
(substitute* "sshoot/tests/test_manager.py"
- (("/bin/sh") (which "sh")))
- #t)))))
+ (("/bin/sh") (which "sh")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "--pyargs" "sshoot")))))))
(inputs
- (list python-argcomplete python-prettytable python-pyyaml))
+ (list python-argcomplete
+ python-prettytable
+ python-pyyaml
+ python-pyxdg
+ python-toolrack))
;; For tests only.
(native-inputs
- (list python-fixtures python-pbr python-testtools))
+ (list python-pytest python-pytest-mock))
(home-page "https://github.com/albertodonato/sshoot")
(synopsis "sshuttle VPN session manager")
(description "sshoot provides a command-line interface to manage multiple