summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-24 22:18:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-25 00:39:38 +0200
commitd0cc1d65249d92647ced94aa8620204b542f7dcd (patch)
tree1a003468800f9870b88a86bfebd09d39d6663450 /gnu/packages/vpn.scm
parent66be80fabb9af0a570aee4c2e96886267a613e8e (diff)
downloadguix-patches-d0cc1d65249d92647ced94aa8620204b542f7dcd.tar
guix-patches-d0cc1d65249d92647ced94aa8620204b542f7dcd.tar.gz
gnu: strongswan: Invoke absolute file names in ‘ipsec’ launcher.
* gnu/packages/vpn.scm (strongswan)[arguments]: Include the ‘ipsec’ launcher script in the 'patch-command-file-names phase. [inputs]: Add coreutils.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 8272a3a26e..aecf9831ca 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -114,6 +114,10 @@ endpoints.")
(modify-phases %standard-phases
(add-before 'build 'patch-command-file-names
(lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/ipsec/_ipsec.in"
+ (("cat|kill|sleep|rm|uname" command)
+ (string-append (assoc-ref inputs "coreutils")
+ "/bin/" command)))
(substitute* "src/libstrongswan/utils/process.c"
(("/bin/sh")
(string-append (assoc-ref inputs "bash") "/bin/sh")))
@@ -179,7 +183,8 @@ endpoints.")
;; Use libcap by default.
"--with-capabilities=libcap")))
(inputs
- `(("curl" ,curl)
+ `(("coreutils" ,coreutils)
+ ("curl" ,curl)
("gmp" ,gmp)
("libcap" ,libcap)
("libgcrypt" ,libgcrypt)