summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-21 23:42:10 +0100
committerMarius Bakke <marius@gnu.org>2020-12-21 23:42:10 +0100
commitbbe4ed65ed5fe7dc8ed9d226042852387cee3b1e (patch)
tree9fbf0642fe71d0d4f6d7cb4e85b4d1587c8b9b16 /gnu/packages/vpn.scm
parent034cfbd2449387c15823cd9ec3e91661f9e5bf49 (diff)
parentf00e68ace070fd5240a4b5874e61c26f6e909b6c (diff)
downloadguix-patches-bbe4ed65ed5fe7dc8ed9d226042852387cee3b1e.tar
guix-patches-bbe4ed65ed5fe7dc8ed9d226042852387cee3b1e.tar.gz
Merge branch 'master' into ungrafting
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 8628d9f4bb..525d1ddb3f 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -317,7 +317,7 @@ this process. It is compatible with Fortinet VPNs.")
(define-public openvpn
(package
(name "openvpn")
- (version "2.4.9")
+ (version "2.4.10")
(source (origin
(method url-fetch)
(uri (string-append
@@ -325,7 +325,7 @@ this process. It is compatible with Fortinet VPNs.")
version ".tar.xz"))
(sha256
(base32
- "1qpbllwlha7cffsd5dlddb8rl22g9rar5zflkz1wrcllhvfkl7v4"))))
+ "0xx378ja2rdfaayc257z0z5ddsp8h0jcpqnd1a6bdw3rlsam6a6g"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--enable-iproute2=yes")))
@@ -349,7 +349,7 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
(define-public protonvpn-cli
(package
(name "protonvpn-cli")
- (version "2.2.4")
+ (version "2.2.6")
(source
(origin
;; PyPI has a ".whl" file but not a proper source release.
@@ -360,8 +360,7 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "08yca0a0prrnrc7ir7ajd56yxvxpcs4m1k8f5kf273f5whgr7wzw"))))
+ (base32 "0y7v9ikrmy5dbjlpbpacp08gy838i8z54m8m4ps7ldk1j6kyia3n"))))
(build-system python-build-system)
(arguments '(#:tests? #f)) ; no tests in repo
(native-inputs