summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/vpn.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 852d0038c7..67ef4a4ae9 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -723,7 +723,7 @@ this process. It is compatible with Fortinet VPNs.")
(define-public openvpn
(package
(name "openvpn")
- (version "2.5.3")
+ (version "2.5.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -731,7 +731,7 @@ this process. It is compatible with Fortinet VPNs.")
version ".tar.xz"))
(sha256
(base32
- "0zlski66mw10klmwvg445z051mld7xjng4iyl4f9b883qr1rjspv"))))
+ "0di4g48kzh5qgm4ri3z6qdjfy23ligmqd7260ynw8f5rgb9drh2n"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--enable-iproute2=yes")))
@@ -1019,7 +1019,7 @@ WireGuard was added to Linux 5.6.")
(define-public wireguard-tools
(package
(name "wireguard-tools")
- (version "1.0.20210424")
+ (version "1.0.20210914")
(source
(origin
(method git-fetch)
@@ -1028,7 +1028,7 @@ WireGuard was added to Linux 5.6.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "12v0ykaz7phv1gqin35wf6ndgb9819vai17ynjxssq00xwcbsq43"))))
+ (base32 "1nafrb2naif0z7z3vijnlyp81z89ywzlagc64k4sqa3ayzn95sm0"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -1046,28 +1046,28 @@ WireGuard was added to Linux 5.6.")
#:tests? #f
#:phases
(modify-phases %standard-phases
- ;; No configure script
- (delete 'configure)
+ (delete 'configure) ; no configure script
(add-after 'install 'install-contrib-docs
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (copy-recursively "contrib/"
- (string-append out "/share/doc/wireguard-tools"))
- #t)))
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/wireguard-tools")))
+ (copy-recursively "contrib/" doc))))
(add-after 'install 'wrap-wg-quick
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(inputs-sbin (map (lambda (input)
- (string-append (assoc-ref inputs input) "/sbin"))
- (list "resolvconf" "iproute" "procps"
- "iptables")))
- (coreutils (string-append (assoc-ref inputs "coreutils")
- "/bin")))
+ (string-append (assoc-ref inputs input)
+ "/sbin"))
+ (list "iproute"
+ "iptables"
+ "procps"
+ "resolvconf")))
+ (coreutils (string-append (assoc-ref inputs "coreutils")
+ "/bin")))
(wrap-program (string-append out "/bin/wg-quick")
#:sh (search-input-file inputs "bin/bash")
`("PATH" ":" prefix ,(append inputs-sbin
- (list coreutils))))
- #t))))))
+ (list coreutils))))))))))
(inputs
`(("resolvconf" ,openresolv)
("coreutils" ,coreutils)