summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-03-07 12:21:37 +0100
committerRutger Helling <rhelling@mykolab.com>2019-03-07 12:23:43 +0100
commit9fd6ad3e3557a8efeadf182af60e32c77b62b2af (patch)
tree7be3a45c797db9d3a3170506cae6a12ef46fdc61 /gnu/packages/vpn.scm
parent9cb4bda22297777dde64d1ca4aad1bb1f42076f3 (diff)
downloadguix-patches-9fd6ad3e3557a8efeadf182af60e32c77b62b2af.tar
guix-patches-9fd6ad3e3557a8efeadf182af60e32c77b62b2af.tar.gz
gnu: wireguard: Update to 0.0.20190227.
* gnu/packages/vpn.scm (wireguard): Update to 0.0.20190227. [arguments]: Disable tests.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index f15b111a92..6475a738d4 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -454,19 +455,20 @@ The peer-to-peer VPN implements a Layer 2 (Ethernet) network between the peers
(define-public wireguard
(package
(name "wireguard")
- (version "0.0.20190123")
+ (version "0.0.20190227")
(source (origin
(method url-fetch)
(uri (string-append "https://git.zx2c4.com/WireGuard/snapshot/"
"WireGuard-" version ".tar.xz"))
(sha256
(base32
- "16yzzy4i0z2zslmyr3kppkvkrxryzwdil6v270w9w5mg65v3rlgd"))))
+ "0ybzycpjjidyiz88kkh67abvp3y30f34252dwpgf3ncj4vyjdnzw"))))
(build-system gnu-build-system)
(outputs '("out" ; The WireGuard userspace tools
"kernel-patch")) ; A patch to build Linux with WireGuard support
(arguments
- `(#:make-flags
+ `(#:tests? #f ; No tests available.
+ #:make-flags
(list "CC=gcc"
"WITH_BASHCOMPLETION=yes"
;; Build and install the helper script wg-quick(8).