summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-13 21:10:24 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-13 21:10:24 +0200
commit98ebc8fd2000fba9ee9300892d9c93957071c09f (patch)
tree156cd54bb468991d2f04fe1fac67da6d4edbfcd7 /gnu/packages/vpn.scm
parent0e4cee0eba9578505e6ce6f1b78e642614856594 (diff)
downloadguix-patches-98ebc8fd2000fba9ee9300892d9c93957071c09f.tar
guix-patches-98ebc8fd2000fba9ee9300892d9c93957071c09f.tar.gz
gnu: ocproxy: Don't use unstable tarball.
* gnu/packages/vpn.scm (ocproxy)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index a50fee666f..364d0a2062 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -213,14 +213,14 @@ the entire VPN in a network namespace accessible only through SSH.")
(name "ocproxy")
(version "1.60")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/cernekee/ocproxy/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cernekee/ocproxy.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1b4rg3xq5jnrp2l14sw0msan8kqhdxmsd7gpw9lkiwvxy13pcdm7"))))
+ "03323nnhb4y9nzwva04mq7xg03dvdrgp689g89f69jqc261skcqx"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)