summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-06-02 23:43:48 +0000
committerLudovic Courtès <ludo@gnu.org>2020-09-09 23:21:56 +0200
commit90a6991385df8d19f76e1caaea732e35f5654821 (patch)
treee2ed74d0bfe1f3405e3d8aada9c0355f9bab243c /gnu/packages/vpn.scm
parent3f3fd3d4996f8a3b6bca8db0e6622c7f3d8adfed (diff)
downloadguix-patches-90a6991385df8d19f76e1caaea732e35f5654821.tar
guix-patches-90a6991385df8d19f76e1caaea732e35f5654821.tar.gz
gnu: protonvpn-cli: Update to 2.2.4.
* gnu/packages/vpn.scm (protonvpn-cli): Update to 2.2.4 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 5bd59e91d2..c704106221 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -53,6 +53,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages nss)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -321,7 +322,7 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
(define-public protonvpn-cli
(package
(name "protonvpn-cli")
- (version "2.2.2")
+ (version "2.2.4")
(source
(origin
;; PyPI has a ".whl" file but not a proper source release.
@@ -333,7 +334,7 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
(file-name (git-file-name name version))
(sha256
(base32
- "0ixjb02kj4z79whm1izd8mrn2h0rp9cmw4im1qvp93rahqxdd4n8"))))
+ "08yca0a0prrnrc7ir7ajd56yxvxpcs4m1k8f5kf273f5whgr7wzw"))))
(build-system python-build-system)
(arguments '(#:tests? #f)) ; no tests in repo
(native-inputs
@@ -342,7 +343,8 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
`(("pythondialog" ,python-pythondialog)
("requests" ,python-requests)))
(propagated-inputs
- `(("openvpn" ,openvpn)))
+ `(("openvpn" ,openvpn)
+ ("dialog" ,dialog)))
(synopsis "Command-line client for ProtonVPN")
(description
"This is the official command-line interface for ProtonVPN, a secure