summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-04 21:07:49 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-04 21:46:55 +0100
commit627c6531f0633c5dbdf640556e3fabe988be1435 (patch)
treeb7cfeceb017bbf6d5b34a28c7761ad2b40d221b7 /gnu/packages/vpn.scm
parent89339a35bd8610ec585da36f3da6ddf116c3fe89 (diff)
downloadguix-patches-627c6531f0633c5dbdf640556e3fabe988be1435.tar
guix-patches-627c6531f0633c5dbdf640556e3fabe988be1435.tar.gz
gnu: sshuttle: Update to 0.78.5.
* gnu/packages/vpn.scm (sshuttle): Update to 0.78.5. [native-inputs]: Add python-flake8 and python-pytest-cov. Remove implied python-pytest.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index e07787c735..0c1410c4ad 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -332,14 +332,14 @@ private network between hosts on the internet.")
(define-public sshuttle
(package
(name "sshuttle")
- (version "0.78.4")
+ (version "0.78.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri name version))
(sha256
(base32
- "0pqk43kd7crqhg6qgnl8kapncwgw1xgaf02zarzypcw64kvdih9h"))))
+ "0vp13xwrhx4m6zgsyzvai84lkq9mzkaw47j58dk0ll95kaymk2x8"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -354,8 +354,9 @@ private network between hosts on the internet.")
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm)
;; For tests only.
+ ("python-flake8", python-flake8)
("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
("python-pytest-runner" ,python-pytest-runner)))
(home-page "https://github.com/sshuttle/sshuttle")
(synopsis "VPN that transparently forwards connections over SSH")