summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-24 02:26:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-24 04:32:48 +0200
commit598afe95c3e4bc79c168cff2c65bd45fb94dc0c1 (patch)
treebc315567ec6a7ddaf49a4f4891a8ec405110d1b1 /gnu/packages/vpn.scm
parentf4ba46a2dfc7135a0563d11b167a9dd83fabb14b (diff)
downloadguix-patches-598afe95c3e4bc79c168cff2c65bd45fb94dc0c1.tar
guix-patches-598afe95c3e4bc79c168cff2c65bd45fb94dc0c1.tar.gz
gnu: wireguard-tools: Cross-compile.
* gnu/packages/vpn.scm (wireguard-tools)[arguments]: Use CC-FOR-TARGET.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index ca7454a338..2378e4ff2e 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -39,6 +39,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system linux-module)
#:use-module (guix build-system python)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages base)
@@ -568,7 +569,7 @@ WireGuard was added to Linux 5.6.")
(build-system gnu-build-system)
(arguments
`(#:make-flags
- (list "CC=gcc"
+ (list ,(string-append "CC=" (cc-for-target))
"--directory=src"
"WITH_BASHCOMPLETION=yes"
;; Install the ‘simple and dirty’ helper script wg-quick(8).