summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorLu Hui <luhux76@gmail.com>2022-02-22 12:15:13 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-22 12:19:44 +0100
commit51736faa00ba3c3966eaffdaed593069aac66c93 (patch)
treed1698183cdef64a1e1839dddcb20fa0274a843d4 /gnu/packages/vpn.scm
parente4779e061056b1a3a3ab56ef817353d86c482611 (diff)
downloadguix-patches-51736faa00ba3c3966eaffdaed593069aac66c93.tar
guix-patches-51736faa00ba3c3966eaffdaed593069aac66c93.tar.gz
gnu: Add n2n.
* gnu/packages/vpn.scm (n2n): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index a82db31e30..2c0b2f15c9 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2022 Josselin Poiret <josselin.poiret@protonmail.ch>
+;;; Copyright © 2022 Lu hui <luhux76@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -39,6 +40,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system copy)
@@ -294,6 +296,46 @@ by creating encrypted host-to-host tunnels between multiple
endpoints.")
(license license:gpl3+)))
+(define-public n2n
+ (package
+ (name "n2n")
+ (version "2.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ntop/n2n")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ph2npvnqh1xnmkp96pdzpxm033jkb8zznd3nc59l9arhn0pq4nv"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'bootstrap 'move-configure
+ ;; Don't execute configure script in bootstrap.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "autogen.sh"
+ (("./configure") ""))))
+ (add-before 'configure 'fix-configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "configure"
+ (("/bin/sh") (search-input-file inputs "/bin/sh"))))))
+ #:tests? #f)) ;there is no check target
+ (native-inputs
+ (list autoconf automake bash-minimal pkg-config))
+ (home-page "https://github.com/ntop/n2n")
+ (synopsis "Peer-to-peer VPN client and server")
+ (description
+ "n2n is a light VPN software which makes it easy to create virtual
+networks bypassing intermediate firewalls.")
+ (license license:gpl3+)))
+
(define-public strongswan
(package
(name "strongswan")