summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-05-31 20:06:12 +0200
committerLudovic Courtès <ludo@gnu.org>2021-06-04 22:34:33 +0200
commit3bbb0ec8888e7ca3bb2bc393c34490f60482789b (patch)
tree72bfd7d9970e79eed83b8cd6263d22a61515ba89 /gnu/packages/vpn.scm
parenta4e38cc2163e3881834887bdd68a79dcf9abfcf8 (diff)
downloadguix-patches-3bbb0ec8888e7ca3bb2bc393c34490f60482789b.tar
guix-patches-3bbb0ec8888e7ca3bb2bc393c34490f60482789b.tar.gz
gnu: vpnc-scripts: Set #:guile argument of 'wrap-script'.
* gnu/packages/vpn.scm (vpnc-scripts)[arguments]<#:phases>{wrap-scripts}: Set #:guile argument of ‘wrap-script’. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index a952e3f0db..33ef87c52d 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -192,10 +192,12 @@ Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
;; Wrap scripts with paths to their common hard dependencies.
;; Optional dependencies will need to be installed by the user.
(lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
+ (let ((out (assoc-ref outputs "out"))
+ (guile (search-input-file inputs "bin/guile")))
(for-each
(lambda (script)
(wrap-script (string-append out "/etc/vpnc/" script)
+ #:guile guile
`("PATH" ":" prefix
,(map (lambda (name)
(let ((input (assoc-ref inputs name)))