summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-07-10 09:03:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-07-10 22:25:14 +0200
commit3308591fec2594d1a4b5cc7254650cd465609b28 (patch)
tree7c6621a63bb83d8f4861a4fb430bcae0e958ea61 /gnu/packages/vpn.scm
parent61adfb00b11cc16a70e60f19fd8e0a838a3ef608 (diff)
downloadguix-patches-3308591fec2594d1a4b5cc7254650cd465609b28.tar
guix-patches-3308591fec2594d1a4b5cc7254650cd465609b28.tar.gz
gnu: sshuttle: Move python-pytest-runner.
* gnu/packages/vpn.scm (sshuttle)[native-inputs]: Mark python-pytest-runner as a test-only dependency, following up commit 447f75825fbe473f0684d4664dde01d9d3a02d75.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 063c8aacbe..aec8c1807d 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -219,11 +219,11 @@ private network between hosts on the internet.")
"12xyq5h77b57cnkljdk8qyjxzys512b73019s20x6ck5brj1m8wa"))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest-runner" ,python-pytest-runner)
- ("python-setuptools-scm" ,python-setuptools-scm)
+ `(("python-setuptools-scm" ,python-setuptools-scm)
;; For tests only.
("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)))
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
(home-page "https://github.com/sshuttle/sshuttle")
(synopsis "VPN that transparently forwards connections over SSH")
(description "sshuttle creates an encrypted virtual private network (VPN)