summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@gnu.org>2019-03-19 08:34:10 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-22 22:49:35 +0100
commit1b17c23ebcabba7264ed2447971fb6409b5cd41a (patch)
treec42279dfdca9d098ff64a74da04c592b1d1962e6 /gnu/packages/vpn.scm
parent0dc7d298a33f83d5f02a962b5f1bd24ee0e8ef07 (diff)
downloadguix-patches-1b17c23ebcabba7264ed2447971fb6409b5cd41a.tar
guix-patches-1b17c23ebcabba7264ed2447971fb6409b5cd41a.tar.gz
gnu: Add xl2tpd.
* gnu/packages/vpn.scm (xl2tpd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 6475a738d4..e164d9aa4c 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -35,6 +35,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages base)
#:use-module (gnu packages check)
#:use-module (gnu packages autotools)
@@ -517,3 +518,31 @@ retrieving configuration of WireGuard network tunnel interfaces, and a patch
that can be applied to a Linux kernel source tree in order to build it with
WireGuard support.")
(license license:gpl2)))
+
+(define-public xl2tpd
+ (package
+ (name "xl2tpd")
+ (version "1.3.13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xelerance/xl2tpd")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1nzkmhi9arwd4smhr07l0sssx46w48z0cblv7xcz25wg4hw86mcd"))
+ (file-name (string-append "xl2tpd-" version "-checkout"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "DESTDIR=" %output)
+ "CC=gcc")
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))
+ #:tests? #f)) ;; no tests provided
+ (inputs `(("libpcap" ,libpcap)))
+ (home-page "https://www.xelerance.com/software/xl2tpd/")
+ (synopsis "Layer 2 Tunnelling Protocol Daemon (RFC 2661)")
+ (description
+ "xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
+L2TP allows you to tunnel PPP over UDP.")
+ (license license:gpl2)))