summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 00:51:59 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 13:31:35 +0200
commit0fd3b422cf964157b1d2ea08233676351af1f10a (patch)
tree66b8515a613048bd03cbb70527663ae090e67b4f /gnu/packages/vpn.scm
parent1eaf8eb7eb78ac291b21de178cecb667a4bef7dc (diff)
downloadguix-patches-0fd3b422cf964157b1d2ea08233676351af1f10a.tar
guix-patches-0fd3b422cf964157b1d2ea08233676351af1f10a.tar.gz
gnu: wireguard-tools: Update to 1.0.20210914.
* gnu/packages/vpn.scm (wireguard-tools): Update to 1.0.20210914. [arguments]: Don't explicitly return #t from phases. Re-indent not to exceed 80 columns.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 330a3271b4..6d0d10d60f 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -1016,7 +1016,7 @@ WireGuard was added to Linux 5.6.")
(define-public wireguard-tools
(package
(name "wireguard-tools")
- (version "1.0.20210424")
+ (version "1.0.20210914")
(source
(origin
(method git-fetch)
@@ -1025,7 +1025,7 @@ WireGuard was added to Linux 5.6.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "12v0ykaz7phv1gqin35wf6ndgb9819vai17ynjxssq00xwcbsq43"))))
+ (base32 "1nafrb2naif0z7z3vijnlyp81z89ywzlagc64k4sqa3ayzn95sm0"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -1043,27 +1043,27 @@ WireGuard was added to Linux 5.6.")
#:tests? #f
#:phases
(modify-phases %standard-phases
- ;; No configure script
- (delete 'configure)
+ (delete 'configure) ; no configure script
(add-after 'install 'install-contrib-docs
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (copy-recursively "contrib/"
- (string-append out "/share/doc/wireguard-tools"))
- #t)))
+ (let ((out (assoc-ref outputs "out"))
+ (doc "/share/doc/wireguard-tools"))
+ (copy-recursively "contrib/" doc))))
(add-after 'install 'wrap-wg-quick
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(inputs-sbin (map (lambda (input)
- (string-append (assoc-ref inputs input) "/sbin"))
- (list "resolvconf" "iproute" "procps"
- "iptables")))
- (coreutils (string-append (assoc-ref inputs "coreutils")
- "/bin")))
+ (string-append (assoc-ref inputs input)
+ "/sbin"))
+ (list "iproute"
+ "iptables"
+ "procps"
+ "resolvconf")))
+ (coreutils (string-append (assoc-ref inputs "coreutils")
+ "/bin")))
(wrap-program (string-append out "/bin/wg-quick")
`("PATH" ":" prefix ,(append inputs-sbin
- (list coreutils))))
- #t))))))
+ (list coreutils))))))))))
(inputs
`(("resolvconf" ,openresolv)
("coreutils" ,coreutils)