summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-30 21:12:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-30 21:15:23 +0200
commit0e2d3ce20e7bd71aaad5baa6b977b9684216b66e (patch)
treeee7e839aedd466c290e72ba9c55d27a05e3356b0 /gnu/packages/vpn.scm
parentf2bc53af70eea7b7147b9e7e40280941866ed128 (diff)
downloadguix-patches-0e2d3ce20e7bd71aaad5baa6b977b9684216b66e.tar
guix-patches-0e2d3ce20e7bd71aaad5baa6b977b9684216b66e.tar.gz
gnu: sshuttle: Rely on $PATH to find a POSIX sh.
This fixes a regression introduced in commit c32863e094d3489d2e08ccb3188988d7c6410976, where the sshuttle client will try to invoke its own /gnu/store/.../bin/sh on the server. Rely on $PATH instead of regressing to upstream's hard-coded /bin/sh. * gnu/packages/vpn.scm (sshuttle)[arguments]: SUBSTITUTE* "sh" for "/bin/sh".
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index de5df5039d..9b1f26aa7d 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -355,8 +355,7 @@ private network between hosts on the internet.")
(substitute* "sshuttle/client.py"
(("/usr/bin/env") (which "env")))
(substitute* "sshuttle/ssh.py"
- ;; Perhaps this is unreachable, but don't let's take risks.
- (("/bin/sh") (which "sh")))
+ (("/bin/sh") "sh"))
#t)))))
(native-inputs
`(("python-setuptools-scm" ,python-setuptools-scm)