summaryrefslogtreecommitdiff
path: root/gnu/packages/vnc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/vnc.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/vnc.scm')
-rw-r--r--gnu/packages/vnc.scm40
1 files changed, 18 insertions, 22 deletions
diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index c6b9d0059b..924e219f10 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -145,7 +145,7 @@
("xdg-utils" ,xdg-utils)
("xkbfile" ,libxkbfile))) ; for nx plugin
(propagated-inputs
- `(("dconf" ,dconf)))
+ (list dconf))
(home-page "https://remmina.org/")
(synopsis "Remote Desktop Client")
(description "Remmina is a client to use other desktops remotely.
@@ -175,21 +175,19 @@ RDP, VNC, SPICE, NX, XDMCP, SSH and EXEC network protocols are supported.")
(with-directory-excursion "vncviewer"
(invoke "make" "install")))))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("gettext-minimal" ,gettext-minimal)
- ("automake" ,automake)))
+ (list autoconf gettext-minimal automake))
(inputs
- `(("zlib" ,zlib)
- ("gnutls" ,gnutls)
- ("libjpeg-turbo" ,libjpeg-turbo)
- ("fltk" ,fltk)
- ("linux-pam" ,linux-pam)
- ("libx11" ,libx11)
- ("libxext" ,libxext)
- ("libxtst" ,libxtst)
- ("libxrandr" ,libxrandr)
- ("libxdamage" ,libxdamage)
- ("pixman" ,pixman)))
+ (list zlib
+ gnutls
+ libjpeg-turbo
+ fltk
+ linux-pam
+ libx11
+ libxext
+ libxtst
+ libxrandr
+ libxdamage
+ pixman))
(home-page "https://tigervnc.org/")
(synopsis "High-performance, platform-neutral
implementation of VNC (client)")
@@ -227,13 +225,11 @@ application which is needed to connect to VNC servers.")
,@(package-inputs tigervnc-client)
,@(package-native-inputs xorg-server)))
(inputs
- `(("perl" ,perl)
- ("coreutils" ,coreutils)
- ("xauth" ,xauth)
- ,@(package-inputs xorg-server)))
+ (modify-inputs (package-inputs xorg-server)
+ (prepend perl coreutils xauth)))
(propagated-inputs
- `(("xauth" ,xauth)
- ,@(package-propagated-inputs xorg-server)))
+ (modify-inputs (package-propagated-inputs xorg-server)
+ (prepend xauth)))
(arguments
(substitute-keyword-arguments
(package-arguments xorg-server)
@@ -362,7 +358,7 @@ where the server is installed.")))
"gcc -I"))
#t)))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
`(("gnutls" ,gnutls)
("libgcrypt" ,libgcrypt)