summaryrefslogtreecommitdiff
path: root/gnu/packages/vnc.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-21 22:18:50 +0200
committerMarius Bakke <marius@gnu.org>2020-07-21 23:54:44 +0200
commit2195ad6bd7df591c1f24b5717203b363bc3e1bfd (patch)
treec3a704acbefde225f2532b4f18dcebf31c72b685 /gnu/packages/vnc.scm
parent938f3190e786baab4116ea826bde21d102396cc2 (diff)
downloadguix-patches-2195ad6bd7df591c1f24b5717203b363bc3e1bfd.tar
guix-patches-2195ad6bd7df591c1f24b5717203b363bc3e1bfd.tar.gz
gnu: libvnc: Update to 0.9.13.
* gnu/packages/patches/libvnc-CVE-2018-20750.patch, gnu/packages/patches/libvnc-CVE-2019-15681.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/vnc.scm (libvnc): Update to 0.9.13. [source](patches): Remove. [arguments]: Add phase to patch 'cc' invocation.
Diffstat (limited to 'gnu/packages/vnc.scm')
-rw-r--r--gnu/packages/vnc.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index a084b30f59..ab89bad7aa 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2019 Todor Kondić <tk.code@protonmail.com>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -233,7 +234,7 @@ where the server is installed.")))
(define-public libvnc
(package
(name "libvnc")
- (version "0.9.12")
+ (version "0.9.13")
(source
(origin
(method git-fetch)
@@ -242,10 +243,16 @@ where the server is installed.")))
(commit (string-append "LibVNCServer-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1226hb179l914919f5nm2mlf8rhaarqbf48aa649p4rwmghyx9vm"))
- (patches (search-patches "libvnc-CVE-2018-20750.patch"
- "libvnc-CVE-2019-15681.patch"))))
+ (base32 "0zz0hslw8b1p3crnfy3xnmrljik359h83dpk64s697dqdcrzy141"))))
(build-system cmake-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-cc-reference
+ (lambda _
+ (substitute* "test/includetest.sh"
+ (("^cc -I")
+ "gcc -I"))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs