summaryrefslogtreecommitdiff
path: root/gnu/packages/vlang.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-10-06 09:45:13 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-10-06 09:45:13 +0300
commit527b27f14c110bda4c02bc3f6ee2efb1129458c4 (patch)
treef6ae74208092d4ffb4e1392b4dec831220a07799 /gnu/packages/vlang.scm
parent6450070b9197516f84ff15d8c8653544ea1fb119 (diff)
downloadguix-patches-527b27f14c110bda4c02bc3f6ee2efb1129458c4.tar
guix-patches-527b27f14c110bda4c02bc3f6ee2efb1129458c4.tar.gz
gnu: vlang: Correctly refer to output directories.
* gnu/packages/vlang.scm (vlang)[arguments]: In custom 'install phase correctly refer to 'outputs'.
Diffstat (limited to 'gnu/packages/vlang.scm')
-rw-r--r--gnu/packages/vlang.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/vlang.scm b/gnu/packages/vlang.scm
index 659f9e01c7..e0b2e7bcfc 100644
--- a/gnu/packages/vlang.scm
+++ b/gnu/packages/vlang.scm
@@ -85,8 +85,8 @@
(invoke "./v" "test-fixed")))
#t))
(replace 'install
- (lambda _
- (let* ((bin (string-append (assoc-ref %outputs "out") "/bin"))
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((bin (string-append (assoc-ref outputs "out") "/bin"))
(tools (string-append bin "/cmd/tools"))
(thirdparty (string-append bin "/thirdparty"))
(vlib (string-append bin "/vlib"))