summaryrefslogtreecommitdiff
path: root/gnu/packages/virtualization.scm
diff options
context:
space:
mode:
authorguy fleury iteriteka <hoonandon@gmail.com>2019-01-10 17:33:30 +0100
committerLeo Famulari <leo@famulari.name>2019-01-11 17:09:20 -0500
commit170436771968dfa272225ea45b63689b900fd317 (patch)
treef022b23b449e73e9155bdf35edde0e6a368890ec /gnu/packages/virtualization.scm
parent81c64748bad51c7449eea8bab4953ecb89d02fa2 (diff)
downloadguix-patches-170436771968dfa272225ea45b63689b900fd317.tar
guix-patches-170436771968dfa272225ea45b63689b900fd317.tar.gz
gnu: Add Bochs.
* gnu/packages/virtualization.scm (bochs): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/virtualization.scm')
-rw-r--r--gnu/packages/virtualization.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 57c5c34da1..9b82535aa7 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1074,3 +1075,30 @@ and the user can specify exactly what parts of the filesystem should be visible
in the sandbox. Any such directories specified is mounted nodev by default,
and can be made readonly.")
(license license:lgpl2.0+)))
+
+(define-public bochs
+ (package
+ (name "bochs")
+ (version "2.6.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://sourceforge.net/projects/bochs/files/bochs/"
+ version "/bochs-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1379cq4cnfprhw8mgh60i0q9j8fz8d7n3d5fnn2g9fdiv5znfnzf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ; No tests exist
+ (inputs
+ `(("libxrandr" ,libxrandr)))
+ (home-page "http://bochs.sourceforge.net/")
+ (synopsis "Emulator for x86 PC")
+ (description
+ "Bochs is an emulator which can emulate Intel x86 CPU, common I/O
+devices, and a custom BIOS. It can also be compiled to emulate many different
+x86 CPUs, from early 386 to the most recent x86-64 Intel and AMD processors.
+Bochs can run most Operating Systems inside the emulation including Linux,
+DOS or Microsoft Windows.")
+ (license license:lgpl2.0+)))