summaryrefslogtreecommitdiff
path: root/gnu/packages/virtualization.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-10-12 19:23:30 +0200
committerMarius Bakke <marius@gnu.org>2021-10-12 21:49:44 +0200
commit0b5e128750ed40d4348f2eb49d328b81dba9181a (patch)
tree0c6ee081e74d25155c1bb674715384a712dc2b7e /gnu/packages/virtualization.scm
parent89ea3ab220bfdefcc1ab4588e7a93913ce4595d5 (diff)
downloadguix-patches-0b5e128750ed40d4348f2eb49d328b81dba9181a.tar
guix-patches-0b5e128750ed40d4348f2eb49d328b81dba9181a.tar.gz
gnu: QEMU: Update to 6.1.0.
* gnu/packages/virtualization.scm (qemu): Update to 6.1.0. [source](patches): Remove obsolete patch. [arguments]: Adjust substitutions for upstream changes. [native-inputs]: Add PYTHON-SPHINX-RTD-THEME. * gnu/packages/patches/qemu-meson-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/virtualization.scm')
-rw-r--r--gnu/packages/virtualization.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 2106ade721..504f199296 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -149,7 +149,7 @@
(define-public qemu
(package
(name "qemu")
- (version "6.0.0")
+ (version "6.1.0")
(source
(origin
(method url-fetch)
@@ -157,9 +157,8 @@
version ".tar.xz"))
(sha256
(base32
- "1f9hz8rf12jm8baa7kda34yl4hyl0xh0c4ap03krfjx23i3img47"))
+ "15iw7982g6vc4jy1l9kk1z9sl5bm1bdbwr74y7nvwjs1nffhig7f"))
(patches (search-patches "qemu-CVE-2021-20203.patch"
- "qemu-meson-compat.patch"
"qemu-sphinx-compat.patch"
"qemu-build-info-manual.patch"))
(modules '((guix build utils)))
@@ -218,12 +217,10 @@
;; Ensure the executables created by these source files reference
;; /bin/sh from the store so they work inside the build container.
(substitute* '("block/cloop.c" "migration/exec.c"
- "net/tap.c" "tests/qtest/libqtest.c")
+ "net/tap.c" "tests/qtest/libqtest.c"
+ "tests/qtest/vhost-user-blk-test.c")
(("/bin/sh") (which "sh")))
- (substitute* "Makefile"
- (("SHELL = /usr/bin/env bash -o pipefail")
- "SHELL = bash -o pipefail"))
- (substitute* "tests/qemu-iotests/check"
+ (substitute* "tests/qemu-iotests/testenv.py"
(("#!/usr/bin/env python3")
(string-append "#!" (which "python3"))))))
(add-before 'configure 'fix-optionrom-makefile
@@ -345,6 +342,7 @@ exec smbd $@")))
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)
("python-sphinx" ,python-sphinx)
+ ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
("texinfo" ,texinfo)
;; The following static libraries are required to build
;; the static output of QEMU.