summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-11-18 07:04:53 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-01 17:53:27 +0100
commitb5d0029771ae7e89cd79a6ef8d1818da877e21b0 (patch)
treed12ed42bca9ace1bcbdef559752b68ec1df97493 /gnu/packages/vim.scm
parent39f4ef59ffc37259de40f67c476a1a720aa8d007 (diff)
downloadguix-patches-b5d0029771ae7e89cd79a6ef8d1818da877e21b0.tar
guix-patches-b5d0029771ae7e89cd79a6ef8d1818da877e21b0.tar.gz
gnu: Add vim-nerdtree.
* gnu/packages/vim.scm (vim-nerdtree): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 59ae6ff04a..aca7c5cac2 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1296,6 +1296,36 @@ by their scope. This means that for example methods in C++ are displayed under
the class they are defined in.")
(license license:vim)))
+(define-public vim-nerdtree
+ (package
+ (name "vim-nerdtree")
+ (version "6.10.16")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/preservim/nerdtree")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1si8qla86ng8cffbmfrk9gss0i3912yw0f1ph4bsiq0kk837lccp"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("autoload" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("lib" "share/vim/vimfiles/")
+ ("nerdtree_plugin" "share/vim/vimfiles/")
+ ("plugin" "share/vim/vimfiles/")
+ ("syntax" "share/vim/vimfiles/"))))
+ (home-page "https://github.com/preservim/nerdtree")
+ (synopsis "Tree explorer plugin for Vim")
+ (description
+ "The NERDTree is a file system explorer for the Vim editor. Using this
+plugin, users can visually browse complex directory hierarchies, quickly open
+files for reading or editing, and perform basic file system operations.")
+ (license license:wtfpl2)))
+
(define-public vim-nerdcommenter
(let ((commit "a65465d321f2f8a74b2ffa540b9b87563f7e12e8")
(revision "1"))