summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-09-22 11:55:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-09-22 12:21:09 +0200
commitb0a1d7ef7df0b5e080a2e2b0529fe4e0cf25bdd7 (patch)
tree2fe66d5af098872830874cc67559e9eeeea91ef6 /gnu/packages/vim.scm
parentb43b9acf15ae06e15ee581927056952c7c88c193 (diff)
downloadguix-patches-b0a1d7ef7df0b5e080a2e2b0529fe4e0cf25bdd7.tar
guix-patches-b0a1d7ef7df0b5e080a2e2b0529fe4e0cf25bdd7.tar.gz
gnu: Add xxd.
* gnu/packages/vim.scm (xxd): New variable.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index f4416a5c5c..dffd6d96c0 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -102,6 +102,27 @@ Vim is perfect for all kinds of text editing, from composing email to editing
configuration files.")
(license license:vim)))
+(define-public xxd
+ (package (inherit vim)
+ (name "xxd")
+ (arguments
+ `(#:make-flags '("CC=gcc")
+ #:tests? #f ; there are none
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "src/xxd")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "xxd" bin)
+ #t))))))
+ (synopsis "Hexdump utility from vim")
+ (description "This package provides the Hexdump utility xxd that comes
+with the editor vim.")))
+
(define-public vim-full
(package
;; This package should share its source with Vim, but it doesn't