summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorHiPhish <hiphish@posteo.de>2019-04-10 13:21:26 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-11 13:46:40 +0200
commit9abfbd79cb063202129c207b3ba977bcfb0a6208 (patch)
tree7065f3946bac96069bb01f5ef0ce4013ec918aa9 /gnu/packages/vim.scm
parent8b87b1bf00f9da8a619643dbaed0aeb4d8e4bee0 (diff)
downloadguix-patches-9abfbd79cb063202129c207b3ba977bcfb0a6208.tar
guix-patches-9abfbd79cb063202129c207b3ba977bcfb0a6208.tar.gz
gnu: neovim: Depend on Lua 5.1, not 5.2.
* gnu/packages/vim.scm (neovim): Use correct Lua version as dependencies Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 56deb12c3d..dadffa3ab1 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -756,7 +756,7 @@ are detected, the user is notified.")))
#t))
(add-after 'unpack 'set-lua-paths
(lambda* (#:key inputs #:allow-other-keys)
- (let* ((lua-version "5.2")
+ (let* ((lua-version "5.1")
(lua-cpath-spec
(lambda (prefix)
(let ((path (string-append prefix "/lib/lua/" lua-version)))
@@ -783,10 +783,10 @@ are detected, the user is notified.")))
("unibilium" ,unibilium)
("jemalloc" ,jemalloc)
("libiconv" ,libiconv)
- ("lua" ,lua-5.2)
- ("lua-lpeg" ,lua5.2-lpeg)
- ("lua-bitop" ,lua5.2-bitop)
- ("lua-libmpack" ,lua5.2-libmpack)))
+ ("lua" ,lua-5.1)
+ ("lua-lpeg" ,lua5.1-lpeg)
+ ("lua-bitop" ,lua5.1-bitop)
+ ("lua-libmpack" ,lua5.1-libmpack)))
(native-inputs
`(("pkg-config" ,pkg-config)
("gettext" ,gettext-minimal)