summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-08-17 11:06:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-17 11:07:23 +0300
commit952a7fc89398baff82843332c73d5e3f3def8562 (patch)
treeb5f11b67e7dd2175d07ea5b901f6aa1ddefc2506 /gnu/packages/vim.scm
parentb2df3aece62bfaa9bbbb390fe48fbf70943bb05c (diff)
downloadguix-patches-952a7fc89398baff82843332c73d5e3f3def8562.tar
guix-patches-952a7fc89398baff82843332c73d5e3f3def8562.tar.gz
gnu: vim: Update to 8.2.1471.
* gnu/packages/vim.scm (vim): Update to 8.2.1471. [arguments]: Adjust custom 'patch-absolute-paths, 'skip-failing-tests phases for changes in the sources.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 5a8011bc76..fe8163465e 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -70,7 +70,7 @@
(define-public vim
(package
(name "vim")
- (version "8.2.1145")
+ (version "8.2.1471")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -79,7 +79,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "01z5hgi7m8d63gl1fgfn4p9rsdaqbl5xn4vr247nbxjq5x5hrs7a"))))
+ "1rd2d8lil0liiyfzcqb2b96l4hn99pzfikpjy4w4z1jd4jkfcx17"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -92,6 +92,7 @@
(("/usr/bin/nawk") (which "gawk")))
(substitute* '("src/testdir/Makefile"
"src/testdir/test_normal.vim"
+ "src/testdir/test_popupwin.vim"
"src/testdir/test_system.vim"
"src/testdir/test_terminal.vim"
"src/testdir/test_terminal2.vim")
@@ -120,21 +121,16 @@
(substitute* "src/testdir/test_swap.vim"
(("if !IsRoot\\(\\)") "if 0"))
- ;; These tests fail on upstream's CI on FreeBSD because they are
- ;; run as root. They fail for us because PID 1 and the test suite
- ;; are run by the same user.
- (substitute* '("src/testdir/test_backup.vim"
- "src/testdir/test_writefile.vim")
- (("CheckNotBSD") "throw 'Skipped: this test fails on Guix'")
- (("'bsd'") "'unix'"))
-
- ;; This test checks how the terminal looks after executing some
+ ;; These tests check how the terminal looks after executing some
;; actions. The path of the bash binary is shown, which results in
;; a difference being detected. Patching the expected result is
;; non-trivial due to the special format used, so skip the test.
(substitute* "src/testdir/test_terminal.vim"
((".*Test_terminal_postponed_scrollback.*" line)
(string-append line "return\n")))
+ (substitute* "src/testdir/test_popupwin.vim"
+ ((".*Test_popup_drag_termwin.*" line)
+ (string-append line "return\n")))
#t)))))
(inputs
`(("gawk" ,gawk)