summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-11-01 11:51:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-01 11:54:59 +0200
commit8f92c44bdda75e00bc45a1540f4a8d7a954e411b (patch)
tree8df0fb0f773b948de33158d57c3907943a586e06 /gnu/packages/vim.scm
parente1370ea8fa41417bedb437b2fc3a066b19f82c52 (diff)
downloadguix-patches-8f92c44bdda75e00bc45a1540f4a8d7a954e411b.tar
guix-patches-8f92c44bdda75e00bc45a1540f4a8d7a954e411b.tar.gz
gnu: vim-scheme: Update to 0.0.0-3.e22fc8e.
* gnu/packages/vim.scm (vim-scheme): Update to 0.0.0-3.e22fc8e. [source]: Use https. [license]: Update to new upstream license.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 8792e178ab..f70729952d 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020, 2021 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Tissevert <tissevert+guix@marvid.fr>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -392,8 +393,8 @@ trouble using them, because you do not have to remember each snippet name.")
(license license:expat))))
(define-public vim-scheme
- (let ((commit "99af6befee8bc7d289a523064336474ae063cee3")
- (revision "2"))
+ (let ((commit "e22fc8e199ef52f2efacd08e71c3add90d83b375")
+ (revision "3"))
(package
(name "vim-scheme")
(version (git-version "0.0.0" revision commit))
@@ -401,12 +402,12 @@ trouble using them, because you do not have to remember each snippet name.")
(origin
(method git-fetch)
(uri (git-reference
- (url "http://git.foldling.org/vim-scheme.git")
+ (url "https://git.foldling.org/vim-scheme.git")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "0w9hnsxg92f1wd83rra0ss07zla7p2r44whr9rqs70hc0xm8ygd6"))))
+ "04h946vr4f8wxap3wzqs69y2v8n50g2zbk22jsg2kxr4c01z5cbw"))))
(build-system copy-build-system)
(arguments
'(#:install-plan
@@ -417,7 +418,7 @@ trouble using them, because you do not have to remember each snippet name.")
(description
"@code{vim-scheme} provides Scheme support for Vim (R7RS and CHICKEN).")
(home-page "https://foldling.org/git/vim-scheme.git/")
- (license license:public-domain))))
+ (license license:unlicense))))
(define-public vim-luna
(let ((commit "633619953dcf8577168e255230f96b05f28d6371")